Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.1.4)

Hi folks!

An update is now available for Android TV and Amazon Fire TV for 4th generation Tablo devices.

This update has some cool improvements and bug fixes so make sure to update to the latest and greatest.

Here’s what you can expect:

Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.1.4)

  • Adds ability to trigger TV guide data update from settings
  • Other bug fixes and performance improvements

As always, if you have any questions or encounter any problems, feel free to post them below or touch base directly with support.


Adding the guide update option to the Android version is great!

… and the extra info you’ve added to what each setting option does? Awesome add.

So far no crashes for Series Info lookup. Very good update, guys – keep it up!

1 Like

AWESOME! Tablo now works on my Pixel tablet. Previously, it would crash when I attempted to watch something.

1 Like

Maybe I’m an idiot, but it took me a really long time to realize that some show’s title text isn’t misaligned (in completed recordings) – it’s centered over the rest of that episode’s info! I thought some new little quirk just popped up with this latest update. (SMH)

The spacing between episodes looks a little odd, but I’m thankful to be able to read more than a couple of words!

(crosses his fingers he’s not the only one that didn’t catch on right away)…


I will want to take more time with 1.1.4 to make sure I have really given it a good test however it looks like you fixed one problem and caused another.

I was having issues with FAST channels either live or with recordings stuttering, freezing and then the TABLO app would close. That appears to be now fixed in the limited time I have tried 1.1.4. I would like a few more days of testing to completely say this is fixed (FireTV 4k, external drive, ethernet).

That’s the good news. The bad news it appears 1.1.4 has caused live NON FAST channel TV to now have a stutter that never happened before. So far it appears to be somewhat minor and no freezing of the picture completely and the app does not shut down. I also would like a few more days to test and verify this.

So I will get back to you after the weekend of TV use to give a complete run down of what issues if any I see.
Perhaps others can chime in as to whether they are seeing the same thing I am.

I noticed one error now gone. Previous version when trying to edit a schedule there was an error message. You had to be very quick to edit from the scheduled screen to get a change. Working fine now.

One thing that is still there. When you go to the library and watch a program, when it is finished and you go back to the library screen it does not show all the programs unless you click on the menu item for the programs again. Sometimes there are none showing until you do this.

One minor navigation annoyance. When going to the library screen the highlight is directly above the programs, but if you navigate down it moves to the menu on the left. I understand it is going to the menu for you to select, but visually I keep expecting the highlight to move to the item directly below it when I hit down.

This is on a ShieldTV Pro.

I’ve been running the new version for about 3-4 days.

Firestick 4K (1st Gen, 2018)
Android 7.1.2
Tablo App 1.1.4
Tablo Firmware 2.2.48

App Crashes

The Tablo app has crashed 3 times, causing either an automatic restart of the Tablo app or return to the Fire TV home screen.

Each app crash occurred after selecting a FAST channel from the guide. Within the first few seconds of displaying the FAST channel, the picture would stutter/freeze, and within 30-60 seconds the Tablo app would crash.

Bad Recordings

I’ve had one bad recording since app upgrade – the audio and video were out of sync. This occurred on both the Tablo Firestick app and the Tablo Android app (on my Samsung S22 phone), so I do not believe this was a Tablo app issue.

Minor Quirks

I still see some occasional minor issues:

In the Library, sometimes the recordings don’t automatically show up. I just navigate through the menu and they magically reappear.

While viewing OTA or FAST channels, when I press the remote “down” button, the bottom-of-screen guide doesn’t always completely populate.

General Impression

In 1.1.3, my biggest recurring issue were Tablo app stutter/freeze/crashes, usually when I was exiting an OTA channel to return to the guide. There have been zero occurrences of this with 1.1.4. I would also occasionally have stutter/freeze/crashes just while viewing OTA or FAST channels. This too is no longer happening.

So far, I feel like this is a much more stable version of the Firestick Tablo app.

Thank you for your review of 1.1.4. I have had some crashes on the FAST Channels with 1.1.4 and also some stutter on OTA channels. So this Tablo update did not completely fix the issues for FireTV 4k Sticks first gen also.

So far I have not noticed any issues with my ONN device but I have not used it much as I have been using it only as a backup for my primary device which is the FireTV 4k. My ONN device seemed to be working fine with 1.1.3 so I don’t know if 1.1.4 really was fixing any issues with it.

This is the problem I have on android after I browse a show under latest the hit back button the thumbnails don’t refresh

1 Like

When this happens to me, I navigate from Latest down to All Recordings, wait a second or two, then navigate back up to Latest, and the thumbnails reappear.

From at least Android 1.1.1 (version available when I purchased my Tablo) through 1.1.4, there’s been an odd glitch when connecting a bluetooth speaker to my television (I have not tested this with an STB). The app returns a blue screen with a “failed to decode audio” error, and once you click Retry, it works without an issue. Just sharing in case others are experiencing this or if it’s related to anything else that the developers need to look into.

For references, this is an “every time” occurrence on my FireTV (TV is up to date with Fire OS – PS7668/3894), but I will do more testing throughout the next day or two to see where else this may be duplicated.

After being on 1.1.4 now since it was released I can say that there are still bugs that need to be fixed. Somehow they can’t seem to make a software release that completely fixes problems.

I still get freezing and stutter and crashes on FAST Live and Recordings. Ditto with Live over the air. They seem to be less frequent and more spotty which is puzzeling. It’s like the software fix came close to resolving the issue but not quite there. This does not make much sense.

I’m sure others with FireTV 4k 1st gen will be seeing the same behavior. So far my ONN device has been fine although I do not use it as much since I am basically putting the FireTV stick to the test since this 1.1.4 release.