Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.0.5 & 1.0.6)

Hi folks -

An update is available or arriving shortly for the newest Amazon Fire TV and Android TV Tablo app for 4th generation Tablo devices.

This update has a lot of small improvements but none that will be visible to users so please make sure to update to the latest if your device doesn’t have automatic updates enabled.

Here’s what you can expect:

Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.0.5)

  • Bug fixes and performance improvements

Tablo Amazon Fire TV/Android TV App (4th Gen) Update (v. 1.0.6)

  • Fix for recordings not being selectable from the library screen on some devices


As always, if you have any questions or encounter any problems, please post them below or touch base directly with support.

1 Like

I am running 1.0.4 on my FireStick (Aug 25, 2023 release). No update is offered. Should I expect a version 1.0.5? If so, any ETA?


Amazon sometimes likes to take its time. It should show up before the weekend is over.

1 Like

Showed up today - thanks,

1.05 does not work on 4k Fire Stick.

I’m unable to select the recordings.

Have tried to reinstall and that does not work.

Can I roll back to 1.04?

I just posted a workaround in another thread. Hope that helps!

What thread?

I think I found a workaround also, but this bug is annoying

Here’s what I posted. You’re right it’s very annoying and something like this should never happen.

Mine is doing the same thing since the update.

It definitely sucks but I have found a workaround.

From “Home” go down to the “Recent Recording” line.

Click a show you want to watch and pick the top option.

If it plays the episode you want you’re good.

If not pause the show.

Then go down to “Up Next”

You should then be able to pick the episode you want.

It’s nuts but it works lol. Good luck!

1 Like

Thanks for confirming. That’s the workaround I found as well, but not being able to get it to work normally is really annoying and selecting older episodes is a PITA.

FWIW , I also have the same problem and the workaround works for me as well.

This bug is damn annoying.

TABLO: WHEN can we expect a new updated version for the Fire TV?

YES!!! Me either! I went to watch my daily news recordings and I couldn’t select anything! They really messed up the app. Then I went to my ROKU device and then i couldn’t watch from their either because the same video kept freezing. Only app that worked right was my Iphone App. But I didn’t pay for a new device to watch tv on my phone. These people need to test their software better before it is sent out.


The workaround did not work for me. Other than ‘up’, the remote is not responsive at all in the episode page to select which to watch. Frustrating!

Hi folks - There is indeed an issue with playing back recordings on some older Fire TV sticks. We’re hoping to push a hotfix for it ASAP.

I want my money back.

My firestick 4k was working just fine until Tablo sent out an email last week to delete channels and rescan. Now my recordings won’t play. They play on my iPhone but not on the Tablo app now. First tTablo wouldn’t function on my 2nd edition firestick so I invest money and buy a new one which was working but now can’t play recordings. Why is your product so full of problems. I’m so frustrated I’m thinking of returning the Tablo device and going back tobTIVO


This is not just on “older Fire sticks”.

1.05 is not working on my NEW 4K Fire Stick.

1.04 worked fine.

I just checked my Firestick 4k+ and it will not play recordings. Navigate to a recording and nothing happens. It plays live TV just fine. I’m sure I’ve watched recordings through my Firestick earlier. Meanwhile my Roku Ultra is working just fine.

Sorry to hear that.

Can you tell us what Fire TV OS that your new stick is running?

And is it the 2023 4K stick or the 4K MAX?

Its the 2023 4k stick, which 1.04 worked fine on.

Now I cannot select individual recordings w/1.05, but have to use the workaround for my Tablo, which is damn annoying…