Tablo 4th Gen Firestick app crashes

Has anybody got the Firestick app to work with the new 4th gen tablo. I’ve tried to they’re both the same second gen fire Stick with voice remote. The app launches slowly, sits at a blue screen for a bit, brings up the main page and then when I try to do anything it crashes. Rinse repeat I’ve reinstalled the application several times, I’ve rebooted the tablo several times, I’ve rebooted the fire stick several times. No combination works. I’m ready to return this piece of junk.

Really a gen 2 fire tv stick. Isn’t that the 2015 model. I have one of those and it struggles to run the fire tv UI and struggles more with prime.

Prime day is oct 10-11. buy something that isn’t 8 years old.

I’m only using these fire sticks because one they said they’re compatible and two there’s no Samsung tizen app yet. I’m only using these fire sticks to try to access this tablo an the CW app which is also not on tizen. Thanks for you “help”

The hdhomerun app, which is mpeg 2, is pretty wonky on the gen 2 . As is the slingtv app. I keep mine around as backup for the roku tablo legacy app.

Well if that’s the case I will just return it and try again once the tizen app is available. I see no need to buy three new fire sticks just for this. Still hoping someone can tell me they’ve actually gotten it to work on each second gen fire Stick If not so be it. Thanks

I’ve tried to hint that it blows on a gen 2.

I would check back when the gen 4 tizen app is working.

Thanks zippy :slightly_smiling_face: That’s exactly what I’m going to do I’ve already requested a return authorization.

Just received and installed my 4th gen today. It works great on my Fire TV Stick 4K Max. However my Roku Ultra will not play recordings.

What does roku ultra will not play recordings? my 4660 ultra seem to play recordings and it’s still on roku os 12.0. Is it the same as described on the roku thread where users are waiting on roku os 12.5

My Roku Ultra 4660X os 12.0 will not play recordings made on my Tablo 4th gen. I select play and I get a blank screen with the show title in the upper left corner. I can click forward through the thumbnails but it will not play them. My FireTV stick 4K max plays them just fine.

All I have used is a FireTV Cube, the newest one, and no problems at all. I want to use my AppleTV devices but not supported yet.

my 4660 play fine. Maybe it’s your roku or tv video settings. While my roku is set for 4K 30 fps it’s not using more then 1080p. Probably because of the HDMI port it’s plugged into

(Solved) I changed every video setting in my TV one at a time and nothing helped. It’s a Vizio that I think is about 12 or 13 years old now. Plays perfectly otherwise and am not about to replace it. I then went into the sound settings and changed something about “SRS TruVolume” and it worked. Well for a while. Turned it off again just to test it out and videos would not play. Turned it back on again and videos would not play. Now why did I do that grrr!!! I then went into my Roku settings. The video is set to 1080P and that’s the best my TV can do so didn’t change that. Went into sound (where I was making some changes yesterday) and turned “Audio Mode” from Auto (Stereo) to just Stereo. “Preferred streaming format” to Auto. And “Digital output format” from Auto to Stereo. And now it plays recorded Videos. Not sure what all this means but it works now, and hopefully will continue that way.

My TV supports 5.1 surround sound.

Maybe this;

SophieCat - I had the exact same problem you are experiencing. I wrote up the solution that Zippy showed… take a look at that post. The bottom line is you will need a newer model Roku that will transcode DD+ to DD so the video (and audio) will play on the older Vizio TV.

As you can see above I was able to get it to work by changing the Roku audio setting(s) to stereo. I assume my TV cannot process any type of DD. None of the sound setting mention DD. The only thing it has is a simulated surround that I don’t use. I like using the built in equalizer. I can get it to sound pretty good and get better volume out of it than I do with the surround on.

I had a second gen firestick and it would not work. So I bought a 4k one. It worked but still have problems. Today the app won’t even launch. I’ve uninstalled and reinstalled to no avail. I’ve rebooted. Didn’t work. All I get is a black screen but then it asks me if I want to exit Tablo. Weird. I think they launch this device way too early. Too many problems. Needs lots of additional work.

Mine works perfectly with the new 4k fire stick.

Both of my Firestick 4k Max (newest and previous model) do seemingly crash the app, as do an Android TV and a FireTV while using them. However, the app’s behavior is to seemingly just restart itself.

Was there anything you’ve done to make your app work properly? I have rebooted, cleared caches, cleared data, deleted/restarted/reinstalled and nothing has seemed to take care of this for me.

Full app “crash”/restart issue.

Glad that there are those out there with zero issues – this is very encouraging!