Tablo 4th gen does not like external hard drive

I had a legacy Tablo for years working with a 2TB external hard drive. (WD My Passport Ultra). When the legacy Tablo died a few months ago, I replaced it with a 4th gen Tablo, and used the same external hard drive… I had real problems getting it set up and configured, until I unplugged the external hard drive. Then, and only then, did I successfully get it set up. I plugged in the external hard drive, and thought all was well. The Tablo showed the external storage, and programs were recording. However, whenever I tried to play a show back, the Tablo would stop and show a spinning circle. This happened multiple times. Finally, I unplugged the external hard drive, and started using only the internal memory. Since then, I have had no further stoppages. What can I do to get the 4th gen Tablo to work with my external hard drive?

I don’t think you can just move the drive…

You really need to format the drive to be able to use it on the 4th gen Tablo.

I did that. After installing the external hard drive, I had the 4th gen Tablo format it.

Sounds like the drive may be going bad. One option is to try another drive. If you don’t have one handy, might be worth contacting @TabloSupport and having them take a look when the drive is attached to see if they can confirm if it’s a drive issue.

I would check to see if there is a firmware update for your hard drive.

I did something similar but what I did after seeing that after Tablo recognized the drive and attached but didn’t format it, I noticed the drive didn’t reflect the full 2TB’s that I knew the drive had and was supposed to be available but thought the drive had only 1.75TB which seemed peculiar without any recordings, but I realized it might be left over recordings from the old Tablo that I had disconnected it from, so I took the drive and formatted it on my computer as NTFS format. I also noticed that the internal flash memory after clicking the reset button underneath and going back to using the flash memory had about 25GBs used after disconnecting the drive so I decided to reset the 4th gen back to the factory defaults by pressing and holding the button underneath for about 30 seconds (don’t know if this was necessary but wanted a clean starting point), which is probably longer than necessary and then went through the initial Tablo setup process again and saw all the flash memory was available again and then attached the external drive and this time Tablo saw the drive and gave the blue “format” button which I did and it formatted the drive for my 4th gen Tablo and everything hooked up and has been working fine since. I’ve recorded about 75 movies, sports and TV series so far as a test and so far so good. Hope it helps.

I posted about this before, when you move the HD to the new white Tablo, it does not see the recordings, only the used space they took up. I had to take mine to computer and clear it then when I reconnected it, it worked fine.

I downloaded the WD Dashboard and ran the Long Test. (Took about 8 hours.) It ended up with an Error 7, so I am going to assume a bad or dying hard drive. I will get another hard drive and give that a shot.

(There was no firmware update available. Since I had formatted the disc with the Tablo, it had been completely erased.)

Thanks for all the help and suggestions.

I didn’t see in your posting where you’d mentioned about the external HDD brand and model. But, you post has relevance to what I am trying to get an idea of. Well, I am waiting for my 4th Generation to arrive by UPS today. Tablo recommends WD Element but local stores do not carry it. So, I went ahead and bought the WD Passport 4TB. Any thoughts I might have unforeseen issues with using WD Passport with the 4th Generation Tablo?

My original post stated it is a 2TB WD My Passport Ultra. You just missed it. The only unforeseen issue I see is that you probably will have to use the Tablo to format the drive after plugging the drive into it. If it is needed, the option will be in settings under the storage tab. (I have a 5TB WD My Passport drive on order at Best Buy. When they open, I will go pick it up.)

Quick search implies an error 7 indicates bad sectors, so sounds like it’s possible it could be the source of your issues.

Getting a 5TB WD My Passport as soon as Best Buy opens this morning. We will see. Thanks for your help. (My wife SAYS that a bad hard drive was her first thought, but she never mentioned that to me, and I didn’t think of it.)

My bad! I was doing a quick rundown in reading through the different postings and replies and missing it somehow. Thank you for your input. I will do as you’d suggested. Can’t wait to set it up!!

Most modern drives will silently replace bad sectors with spares. Usually the only time you see bad sectors is when it runs out of spares. In the Dashboard software, Under tools where you have the two tests, there is a tiny link under the S.M.A.R.T text. That will show the data. Spare Block Remaining is the one to keep an eye on.

After getting my replacement hard drive, I have 2 suggestions. 1. Set up the Tablo and get it fully configured and working WITHOUT the external drive attached. 2. Once the Tablo is fully set up and configured, unplug it, plug in the external hard drive, plug the Tablo back in, and after it boots up, go to Settings>Storage and click on Format the hard drive.

OK. New 5TB WD My Passport drive attached and formatted. I recorded 3 hours of random programs as a test, and all 3 hours played back without a hiccup. My problem was a faulty hard drive. Problem solved. Thanks everybody.

And you are powering this only thru the USB port?

Yes. I looked at an 8TB desktop drive, but it required a 120v outlet and was 4 times bigger. I got the 5TB portable drive because it was smaller and was powered by its USB connector.