Tablo (4th Gen) App on Firestick 4K Occasionally Terminates

I’ve had the Tablo 4th Gen for about two weeks and my my issue is with occasional app lockups when running on my Firestick 4K.

This can happen when watching live TV, recordings, or hitting the remote’s back button. The app will freeze (for example, if I’m watching live TV the picture will stutter for 5-10 seconds, then the picture freezes), and if I wait about 30 seconds, one of two things happen:

  1. The Firestick returns to its home screen, or
  2. The Tablo splash screen is displayed and the Tablo app restarts.

Sometimes I can go hours without this happening. Sometimes it happens multiple times in an hour.

If I had to guess, it looks like the Tablo app is running out of memory, or having some sort of buffer overrun. When this happens, the Tablo app terminates and resolves in one of the two ways described above. I’ve been a software developer for too many years, and the behavior “feels” like one of those two issues. Since Firestick apps are usually written in Java, I’m guessing there are some memory management issues in the Tablo app code.

When the Tablo app terminates, the Fire OS/Android reclaims any memory it was using, so when the Tablo app restarts it runs fine (for a while).

I’m wondering if others are seeing similar issues as well.

[On a possibly unrelated topic, I’ve found that exiting the Tablo app by backing out and explicitly exiting reduces the general flakiness of the Tablo app. The Tablo app doesn’t seem to wake up cleanly from being suspended. If I exit by clicking the Firestick remote’s home button, go to another app (e.g. Netflix) then return to Tablo, I’m almost guaranteed to see it lockup.]

1 Like

What generation of firetv stick 4k are youusing. There are at least 2 generations withthe gen 1 using the older fire os 6 android 7.1 and the newer using fore os 8 android 11.

I have a gen 1 and I may not be using it enough to see that problem. But the playback is darker then roku.

I’m using the version released in Oct. 2018. It works great, and the Tablo app is fine most of the time, but I suspect the Tablo app code may still have a few issues.

That version has a 1.7ghz processor and only 1.5g of RAM.

Even with the 2nd gen 4k max, there had been an occasional time where it would restart the app, but with the last firmware and software update, it’s been less frequent.

I can go for days without an issue, and after the 2nd or 3rd time it happens, I will do that cache reboot (hold OK+Play/Pause) and I’ll be good for awhile again. With something that much older, though, it’s likely you’re running out of RAM a little faster. Another thing to try is to download the Background Apps and Process List app to find out what else is running in the background so you can stop them and clear up some more RAM for the Tablo.

There are other apps that need to be sideloaded that will do a quick RAM clear, but obviously that’s a little more in-depth than this.

Also, how much space is left on your internal memory for your Firestick 4k?

Darker because of HDR? Or HDMI setting? or if you swap them out, is it still darker?

That is the gen 1 which is the one I have. Since most of my recordings are on legacy models I probably don’t use the app long enough at a time to see the problem and I’m too lazy to use developer mode. But I have been tempted to trick play into the roku platform menu since that app seems unpredictable.

When I get home this evening, I’ll see how much internal memory I have left. I recently uninstalled a bunch of apps I no longer use, so that helped a little.

That cache clear will help you clean up any leftover space as well.

Good luck and keep us posted!

The HDMI port previously had a fire TV stik gen 2 with no problems. But the gen 1 4k was noticeably darker. The amazon forum indicated users had this for loose fitting HDMI. Especially since some of the newer sticks are heavier then older models. And I use the supplied poiwer adapter which can make it even heavier.

Reseating the HDMI helped a little and I’m not pulling and replugging HDMI ports for working STB’s just for this. The HDMI ports are already very close together


Guess all you can do is bump up that port’s video setting. Good to know if I ever acquire an older firestick!

I installed the Background Apps & Process List app on my Firestick 4K. It showed I had 12 apps running in the background! Even when I rebooted the Firestick (via OK+Play/Pause) it still showed those 12 apps. I used the Background Apps app to Force Close all of them, then rebooted the stick again to make sure they were gone.

I used the Tablo and TCM apps, then rebooted, and both were still shown as running in the background after Firestick reboots. I don’t know how much internal memory is required to maintain an app in the background, but I’m sure it’s non-zero. Is there an app that can show the current amount of internal memory (RAM) the Firestick is currently using?

I’ve been running the Tablo app for the last few hours since then, and it crashed once: when I used the remote’s back button to exit an OTA show, the channel’s picture “stuttered” for about 5 seconds before freezing. I waited about 30 seconds and I was bumped back to the Firestick’s home screen. When I restarted the Tablo app it worked fine, and has worked fine since.

I’ve had this behavior – freezing, followed by the Tablo app terminating when attempting to back out to the channel guide – several times since getting this device two weeks ago. I’ve always been able to restart the app quickly but it is annoying.

With that said, there’s still a lot to like about this (my first) Tablo. I’d like this to replace my Fire TV Recast, and I think once the Tablo folks work out some of the software kinks it’ll be a good product for me. It’s guide and the ability to explore upcoming shows by categories have been a better experience than the Recast.

Glad things are getting a little bit better.

Are you using the reboot command from the settings menus or that force one I mentioned?

Some apps will always load in the background, and you’ll never get your RAM as high as you’d like, but that trick I shared is the fastest way to clear it up. If you’d like to check out a free app to see how much RAM is in use, there is one called “Developer Tools Shortcut for Fire TV.” If you install it and enable toe “System X-Ray” option, you can get an on-screen idea of what your system is up to. The overlay will stay up until you go back into the app and turn that X-Ray feature off, or restart your device.

That should be a start, but there are plenty of YouTube tutorials out there that will give you an idea of how to sideload other 1-click “force quit all” type of apps, but you’re left to your own devices on how safe they might be. Unfortunately, the guy I trust most (TechDoctorUK) has his own app now and his previous links are no longer available (I did not search too hard and cannot remember the name of any specific ap).

I hope this helps at least a little bit!

Thanks for all your help and suggestions!

I installed the Developer Tools Shortcut app and enabled System X-Ray. While running the Tablo app, app memory usage tends to stay in the 360-400 Mbyte range, and available memory is in the 160-200 Mbyte range. While “exercising” the Tablo app, I kept an eye on the app memory usage and didn’t see anything that indicating my original theory of an app memory leak.

I did have one Tablo app termination while X-Ray was running (the screen went to black, then in about 30 seconds returned to the Firestick home screen) but I wasn’t paying close enough attention to notice if app memory did anything squirrely. I’ll keep monitoring it over the next few days to see if these app terminations follow any patterns.

1 Like

I use the new Tablo White-2 tuner version, on (2) separate Fire Stick 4k Max devices. Everything is only about two months old. I have exactly the same problems as everyone else has on the Fire Sticks.

Both of my 4k Max Fire Sticks have 16 GB internal RAM and both have 4 GB+ unused RAM, so that’s not the issue. I also use the Tablo on my Fire 10 Tablet, with no problems at all. And, I use it occasionally on my PC running it through an app called Bluestacks app player that allows android apps to run on a PC. I let it sit on an OTA station for hours, when I return, it’s still playing. The hang ups, buffering, stuttering, not starting up, are all related to the Fire Stick 4k Max version of the software.

My wife wants to simply watch TV, not make a hobby out of trying to make it work, so I get all the blame.

At times, repowering the Tablo has helped, or doing a Tablo app force stop on the Fire Stick. I even went so far as plugging the Tablo, which is way up stairs, into an Alexa plug. And, plugged the Fire Stick power supply into a different Alexa plug. Then, I made a routine in Alexa called “RESET”. Through the remote I hold down the Alexa button and say, “RESET” and both the Tablo and Fire Stick power off for 10 seconds, then power back on. I also have Alexa voice messages telling what’s going on, and when the RESET is completed, after about 45 seconds. This complete powering off/on both devices, gets them working for now, but does not solve the issues everyone’s having with the Fire Stick 4k Max and Tablo White. And, it’s also nothing to do with my apps running in the background.

I’m a retired computer/design engineer for a major vendor of retail and financial systems. I spent a lot of my life programming and patching programs, and interfacing things that were not originally meant to work together.

Bottom line is Tablo needs to fix the Fire Stick 4k Max interface or guys like me will keep getting blamed by their wives for buying more electronics just to make things worse. Now she just uses the TV in OTA mode with an inside antenna and gets the couple of stations she cares about.

I wanted to add to this post about the Tablo splash screen popping up while you´re watching a live station. It just started happening on both Fire Sticks for no apparent reason, but the tablet and PC versions were OK. The only fix for this was to reload the Tablo software. Instructions are on the Tablo site, but basically go into your Tablo account and sign out. Then hold down the Tablo reset button for 7 seconds. Stuff happens with the Tablo LED but not exactly what the on line instructions say. Sign back into your account and install from there. Connect to WiFi, etc. Not a straight forwrd procedure and it hangs and needs to be restarted to get the WiFi password accepted. This Tablo install also needs some work. Takes from 30 - 45 mins, and you lose everything recorded.

But, it did fix the splash screen appearing at random, and it insures you have the latest updates.

I know I’m a couple of months late in answering to this post, but experimenting with intermittent problems and trying different work arounds are time consuming.