Tablo 4 DVR will not recognize usb hard drives (No Hard Drive Connected - error message)

I too had the same issue. I’ve bought it less than 7 days ago. The USB ports are not up to specs. I had to pull the usb cable slightly back and gave it a slight turn for Tablo to power the hard drive.

Should I return it to Amazon or work with Tablo Support for return?

Can’t use an SSD for some reason. Perplexing indeed.

I started using a USB HUB. I plug the HUB into the Tablo, the Drive into the HUB, and power the HUB with the Wall-Wart. It seems to be working great. I’m not sure if relieving the power requirement from the Tablo is helping, or ( probably from what I’m reading now ) the connector combinations are more snug. I did have Tablo advise me to get a Monoprice cable, which I did order and have received. However, I’ve been hesitant to try out the new cable since this works so well.

I’m experiencing the same issue where I plugged in my 2TB WD Elements drive when trying to boot up my used Tablo. No power is going to the HDD. I tried to even charge my phone to see if the USB port is proving power and neither of the ports provide any power to charge the phone. I’ve contacted @TabloSupport with a support ticket. I think that these USB ports are dead.

Did you say used? You might have to return it to the seller. The warranty on the Tablo is only for the originally purchaser.

Man, that really sucks.

It does. But no manufacturer honours the warranty on used goods, no electronics manufacturer anyway. You always need proof of purchase.

@Genghis1227 We’d have to take a look at the ports to be sure - but generally @theuser86 is correct. To be replaced, the Tablo has to come from an approved retailer; e.g Amazon, Best Buy, etc.

I have the same issue with the WD Elements and the original USB cable. Sometimes it recognizes the drive and sometimes it doesn’t. If I wiggle the connection, it comes back. I have connected the drive to a PC. THE USB connection fits snugly. I ran a successful extended rest. The connection to the Tablo seems loose. It. It would seem defective to me. What is the suggested solution?

I replaced,the USB cable with a USB2 version. Picture issues went away, such as pixelation and waits. However the Tablo would reboot every couple of minutes. So I just remove the drive to see what would happen. My display issues are still gone. However I can only watch one TV and I can rewind about three minutes.

Summary: the drive performance was causing lots of other issues. Since I ran an 18 hour diagnostic on the drive with a PC with the USB cable that came with the drive, I don’t think that is my issue.

What is my next step?

@Bruce_Beck - Pop us a note so we can take a look at your ports:

I am available for a couple of hours. What do you need?

@Bruce_Beck - If you’re available right now, it’s best you call and speak with someone directly:

I have the same issues with my tablo and have not had any solutions yet. Tablo will never admit that it may be a hardware problem. Have my tablo for almost 1 year, lifetime member and my tablo is still unusable. getting an email response every 5 days does not work for me. I need a replacement. My hard drive work perfectly in a PC I have been reformatting it many times, read/write tests all OK. Plug it back in the TABLO usb, it recognizes there is a drive and asks to be formatted. 5 seconds later is says that there is no hard drine attached. so frustrating.

Tablo does admit to hardware failures and does replace Tablos under warranty, see here for proof.

It may be for you but I have this problem for 6 months now, I told them this is a hardware problem and they still do not admit it. I tried many many times to get the unit in a remote mode and it does not work. They insist they want to remote it. I had and still have a lot of patience but this is ridiculous.

@Liviu_Imbir A remote session is usually easy to start - and it’s fairly quick for us to determine whether or not there are any hardware issues. This way we can confirm a hardware issue and send a replacement - instead of just doing the latter and seeing the same problem all over again.

If you’re having a hard time setting up a remote session, feel free to PM me or call us; we can walk you through it.

I am available again to do the remote connect

Again, I am home only on Friday and that is the only time I can call you.
How is 7:00 AM Pacific Standard time on Friday Feb. 5 (9:00AM Central Standard time) for a

By the way the hard drive and all the USB cables I have works with no
issues on PC. I formatted, reformatted, read/write tests, and no issues at

Our support hours are: Monday-Friday 9:30 AM - 5:30 PM ET.

We understand this isn’t ideal - fortunately remote access will work without us having to do it ‘live’ over the phone.

You can even put the Tablo into remote access tonight, let us know, and it will stay that way until we get to it in the morning.