Switch from Eth to WiFi after Eth damaged by lightning

We had a lightning strike very close to the house recently and it took out a couple of power supplies and Ethernet connections. One of the power supplies was for my Tablo and after replacing that I found it had also damaged the Ethernet port on the Tablo. Interestingly enough, I had an Ethernet cable at the other corner of the house fried by this same event .I’ve never seen that before, but I’ve replaced the cable & all is good there again.

I’m sure the Ethernet port on the Tablo was damaged because I’ve verified other devices work with the same wall jack & cable which previously worked with the Tablo. Initially the lights on the Ethernet jack were behaving abnormally and were very dim, but now they don’t illuminate at all.

After realizing (accepting) that the Ethernet port was blown, I was able to switch the Tablo to connect to my router via WiFi (I don’t recall the exact steps I followed, but it included finding the Tablo AP and temporarily connecting my phone to it to select my home WiFi and entering the PW) and I was able to access it again to view the guide, etc. However, a couple days later I couldn’t access the Tablo from any of my devices - Roku, mobile app, smart TV app, etc. I found that the light on the Tablo is continuously slow blinking. I’ve tried resetting via a quick tap of the blue button, power cycling, full reset by long pressing the blue button, but cannot get the Tablo to show up again.

It seems like my Tablo is dead now. I’m pretty sure Ethernet is toast and my only hope is to get WiFi working again, but I can’t seem to get the temporary Tablo AP to show up anymore (maybe because WiFi is now dead, too).

Anyone have suggestions of other things I might try to revive it?

What are my options? Can I send the unit in for repair?

I purchased the lifetime subscription for the guide over a year ago, so I think that’ll cover any unit I get to replace this one, right?


Your subscription will work on a new device.

As for the rest, contact Table Support.

First, try this:

If not, do these steps not work to get the WiFi access point back?

Yeah, I already tried those steps.
And I’m certain that the Ethernet cable is not connected.

Bummer. Well, drop a note to support and we can help confirm and work with you on next steps.

Your lifetime guide can be applied a new unit should it need to be replaced.