Support for Multiple Routers

It would be great if Tablo would work on Networks with multiple routers. I have two routers on my network and can only use the Tablo on the TV/Roku which is connected to the same router. Although the rest of my Network is seamless, only the Tablo does not work across routers. Is this a feature that could be addressed in a future update?

That’s a very unusual network setup. Why two routers? Do you have multiple Internet connections? Are they both connected to the same ethernet switches? Are they both running DHCP?

Do you actually have multiple routers, or multiple Wifi Access Points?

What’s the network number for each router? What client IP addresses work and which don’t?

I have two routers on my network and it works fine. My setup is like this…

Router/modem - this is the ISP supplied POS, but I have to have it to get internet. This has Wifi and ports on the back…its also running DHCP.

Router 2 is a Cisco E4200 running Tomato firmware…which is connected to the ISP router from one LAN port to another on each device (ie i’m not using the “internet/wan” port on this one). DHCP is disabled here.

I can connect via wifi or hardwire to either and access the tablo (which is connected to Router 2 via hardwire).

I have it setup this way because router 2 has 5GHz wireless N whereas the ISP doesn’t. I also just moved and didn’t want to reconfigure everything, so I just turned everything on and they reconnected just as before to router 2.

Yes, but in your case, router2 is acting as an AP and a switch, right? It’s not really ‘routing’, i.e. using DHCP. Router1 is assigning your IPs and everything is on the same subnet.

Basically, it currentlly works like this…

If Tablo and supported devices are on same subnet, all supported devices can connect to Tablo.
If Tablo and supported devices are not on same subnet…

  1. Tablo Connect must be enabled.
  2. Supported devices must be synced with Tablo within same subnet, before attempting to remotely connect when outside same subnet.
  3. Not all devices can utilize Tablo Connect feature, i.e. Roku.

So, if you have the following, it won’t work…

  1. 2 routers on 2 different subnets (double NATing).
  2. Roku connected to different router than Tablo is connected to.

Yes that is correct.

I guess it depends on the use case and what the objective is - why does @Usbillerb have/need two routers?

That’s what we are waiting to find out so we can help further. :wink:

wouldn’t it work (even if they were on 2 subnets) if the tablo was on the 1st/main router? I was under the impression that the second router’s devices could talk to the 1st devices if they were the ones that initiated the conversation…and of course all of router 1’s devices can talk to each other.

There is some distance between my primary router (the one connected to my cable modem) and the mancave, where I have the Tablo. I needed more ports in the mancave and had the extra router, so basically use it as a switch but thought it would be convenient to have an additional access point in this location as the primary signal is weak here. The AP is not a necessity so if I were to swap the router out for a switch, would that solve my problem?

No, not using a Roku.
It can work using other devices like a tablet, and having Tablo Connect enabled.

True, but this functionality is not built in to the Roku.
I don’t believe it’ll work with a ChromeCast, either.
They have to be on the same subnet as the casting device, like your computer, smartphone, or tablet.

If you can put the 2nd router in bridge mode and only use it as an AP, you should be good to go.

There is some distance between my primary router (the one connected to my cable modem) and the mancave, where I have the Tablo. I needed more ports in the mancave and had the extra router, so basically use it as a switch but thought it would be convenient to have an additional access point in this location as the primary signal is weak here. The AP is not a necessity so if I were to swap the router out for a switch, would that solve my problem?

Maybe. Depends on if you actually configured this second router as just a switch and AP, or if it’s acting like another router, which is a no-no. Are you using the WAN port on this router to connect to the main router, one one of the LAN ports? And did you make sure to turn DHCP off on this device?

1 Like

This article has a good explanation of the issues and solutions. Basically you want the second router as a switch, so disable dhcp on it and have it connected from its LAN (not internet/wan) port to the primary router.

http://www.smallnetbuilder.com/lanwan/lanwan-howto/24431-howtotworoutersharing

I have not really configured the router at all, except the basics- SSID and security features. I suppose I did a ‘no-no’ because I just plugged it in and assumed it would manage itself. I’m not a network guy and only know enough to (apparently) be dangerous. I have connected it via the WAN port, connected to LAN port on the primary router. I have not turned off DHCP.

Thank you. That makes sense.

Yes, and we do, too. :slightly_smiling:
It’s just that some of us have already gone thru your situation.

1 Like

Put the POS router (from your internet provider) into “Bridge Mode” and let your “good” router do all of the work.

I did this with the crappy wifi DSL router that Centurylink requires me to use. I put the router in bridge mode, shut off its wifi capabilities and just let my good router handle the login to Centurylink, as well as DHCP and wifi duties.

In this configuration, I have no Tablo Connect issues.

1 Like

I agree, put the ISP modem in bridge mode.

Many ISP routers don’t support bridge mode. But many non-isp routers support a router-behind-router configuration In this mode the DHCP server is on the ISP router and feeds IP addresses to every device down the line.

Thus all devices are on the same subnet. The non-ISP router still acts as a router for those devices directly connected to it. Some non-ISP routers will detect that they are in router-behind-router and configure it’s self. If the router has ever been setup as a stand alone router it sometimes needs a factory reset so that it auto-detects the new configuration.