Stuck at "Connecting..."

Hi all,

I’ve been lurking here for about a year, but finally broke down and bought myself a 4-tuner Tablo. I got it working at about midnight last night after several hours of struggle. I have a background in IT and home media systems, so I thought it would be a snap, but that was not the case.

Anyway, after who knows how many reboots of the Tablo and my laptop, it finally occurred to me that Tablo might be confused somehow by my multi-WAN router, so I disabled one of the WANs, but still no luck. I finally disabled the other of the two WANs and finally got connected to the Tablo. Wasn’t too happy about what it took to get there, but I did make it through setup and finally got to see the interface and some video on my notebook. Yay! Hooked up my Roku 3 and got that working too. Made some recordings, did some quick quality comparisons to my SageTV setup and was feeling pretty optimistic until the Roku unexpectedly rebooted itself.

After that, it wouldn’t connect anymore. Notebook still worked, so I did a hard power cycle on the Roku, and then it could connect to Tablo once again. At that point it was about 2:00 AM, so I decided to quit while I was ahead and call it a day.

When I finally got back around to it this afternoon, it was working fine from yet another PC as well as my iPhone, so I decided to try my luck with turning my primary ISP back on. After that, I couldn’t connect from any device. Max in Tablo Support said, “…our server has no way of knowing that your Tablo’s external IP has changed which is why the web app didn’t work. To fix this a reboot of the Tablo is required.”

Well, many reboots later, it still wasn’t working, and I can only assume that is because the router is intentionally trying to balance the load between the two WANs, constantly confusing the Tablo server. Honestly, I think the Tablo should just give the server a shout and tell it where it is when a client tries to connect, similar to what GoToMyPC does. I mean, with a dynamic IP address, sooner or later it’s going to change, so if Tablo’s software design assumes that it will always be the same, that if faulty logic. It virtually guarantees that the Tablo will fail multiple times because of this alone.

Putting that troubling thought aside for the moment, after reading Max’s note, I tried to configure my router with an Outbound Policy Rule (using TCP), basically attempting to make it so that all outbound traffic from Tablo would traverse the same WAN, and thus the Tablo server should be less confused by traffic from my secondary WAN IP. That got me connected via web browser (with both WANs enabled), but I still couldn’t connect via iPhone. Just a minute ago I killed the secondary WAN, and that made the iPhone start working again, so obviously my router configuration attempts did not produce the desired results.

Mind you, in all of these scenarios, the client can see “Mark’s Tablo”, and it sees the Live TV guide, but it never can connect. I have tried it via Wi-Fi on the same LAN, but no connection. I then manually opened the required ports on my router and tried it via LTE, but got the same results. It passes the port test and indicates “Your Tablo is ready for remote access.”, but I can’t access it with the iPhone anymore. Very frustrating. I’m just not getting enough feedback from Tablo to tell what’s wrong. And I have never seen it work via LTE, so not sure if that is related or not.

So I am wondering, do any of you have any experience using Tablo with multi-WAN routers? And if so, were you able to make it work? Any suggestions will be greatly appreciated because as much as I am liking the Tablo’s potential, it would not be practical to abandon an expensive business-class multi-WAN router that works great with anything and everything except for Tablo.


I would be interested to see what would happen if you forced your iPhone to have the same outgoing WAN policy as you set up for your Tablo. Without knowing the inner workings of the Tablo I would guess that it is getting messed up because the client device and Tablo have different WAN IPs, so it might be trying to connect to the Tablo as if it was remote.

I suppose I could do that, but if I force all of the potential Tablo clients to WAN1, that would be pretty much invalidate the time and money I spent to get redundancy. But I could do it as an experiment, if you think it will get us any closer to a real solution. If I had a better understanding of what Tablo is doing, then maybe I could give it what it wants, but I have not been able to find much in the way of technical information. I can’t think of any good reason to force all clients out to the cloud for authentication. It seems like it would make an awful lot more sense to authenticate right on my own LAN, unless I was actually trying to connect from some remote location. I think that watching TV on my phone has a cool factor, but the times when I would actually do that are few and far between. I think that remote streaming should be the exception, rather than the rule. And if I have to knock holes in my firewall anyway, then it might still make sense to let my own Tablo device handle the authentication. Unless the reason is to inspire subscriptions. Personally, I hate never-ending monthly expenses. That’s why I’m messing with a Tablo instead of just getting cable TV. I would rather buy a lifetime subscription, assuming I can actually make it work without crippling my network.

And it does raise a bigger question too, which I hate to even bring up as a newcomer to this forum, but what if Tablo goes broke? It seems like we would all be stuck with something like $500 worth of hardware that we couldn’t use at all. This is the same feeling that I’ve had with SageTV ever since they sold out to Google. That’s why I become interested in Tablo. For some reason, Sage has continued to function, but with no support, even something as simple as a Windows update could kill it at any time. In fact, that has essentially already happened with the Windows client, with the most recent Java update. If that’s where I’m headed with Tablo, maybe I would be better off to just bail out now and go buy an (arguably) over-priced TiVo solution. Not that they couldn’t go out of business too, but they do have a large user base, paying for subscriptions, so that part of the business might well survive.

It would be a shame though…I think Tablo has a lot of potential. And I really do like to see the little guys win. I really want to make it work.

Yeah I was thinking you should try it mostly as an experiment. It would at least tell you if multiple WANs was the cause of the problem. There may be some other ways around it after you determine if it works.

Sorry to hear about your networking woes. But yes, try that experiment.

Without your iPhone making a connection to the Tablo locally, it will not be paired to your Tablo and thus not be able to access the Tablo remotely even if your appropriate ports are forwarded. This is likely why the connection over the LTE did not work when trying to use Tablo Connect.

As well, if you have two WANs and the iPhone app goes through your 2nd WAN to make the local connection to the Tablo (say you’re on the WiFi at home) then it will treat this as a remote connection (aka Tablo Connect). Again, the connection won’t work “remotely” because of the fact you have not paired the iPhone locally to the Tablo.

@MrMark Keep us posted on how this turns out, Mark. Feel free to PM be directly as well! Our support team is ready to help :smile:

Thanks, will do. It’s still not working, as of a moment ago.


Hummm…well, if I disable one of the WANs, (and reset the Tablo) then everything works fine, so I think we can safely assume that the dual WAN situation is contributing to the problem. With that said, the iPhone has successfully paired with the Tablo at several points,so even if Tablo interpreted the changed public IP address as being “remote”, then it should have just gone ahead and connected remotely, right?

The whole connection logic just seem too fragile…susceptible to any number of uncontrollable factors. For example, even if I just had Comcast as my only ISP, with a plain old garden-variety consumer router, what if we have a power glitch in the neighborhood? I have everything here on UPSes, but Comcast certainly doesn’t, so a power glitch quite often results in a new public IP address. And we have minor blips like that all the time, so if Tablo incorrectly assumes that a dynamic IP address will be persistent, it pretty much guarantees failure. If authentication must take place in the cloud, then there has to be some way for individual Tablo units to report their actual IP addresses to the cloud.

Maybe I am missing something, and if I am, I apologize in advance. I’m just frustrated that something that should be so simple is turning our to be so troublesome.

I just tried some new router settings. Afterwards, I did a hard power cycle on everything. Cable modem, router, etherswitch, tablo.

Lo and behold, both my PC and my iPhone could connect to Tablo via my LAN. Being emboldened, I then switched my iPhone to LTE, and to my great surprise and pleasure, that worked too. Crazy, right?

So then. realizing that I was burning through LTE data, I wondered how low I could set the Remote Streaming Quality and still get an acceptable picture. I kept turning it down, step by step, all the way down to 500 kbps, but never could tell any difference. At that point I started to get suspicious that it wasn’t actually working right, so I turned it down to 64 kbps (Audio Only) and guess what - that didn’t make any difference either!

I tired it with both live TV and with a recording, but both ways, it was showing good quality video, even when set to 64 kbps audio only!

I really would like to understand what in the world is going on here…

@MrMark when you changed the remote streaming quality did you change it on the same device you were remote streaming through? I’ve noticed each device can have its own remote streaming quality setting and is not universal like the recording quality setting is.

@KyleR, sorry for the delay…the forum did not send me a notification for some reason.

But yes, I did. Actually, I’ve tried changing it on both the PC and iPhone, but I can’t tell that it makes any difference where I set it. I found an old thread where someone had the same concern, but no answer was ever posted.

Have you personally seen it make a difference?