Sony TV can't install app


Trying to install the Tablo app on my Sony TV that runs Google TV. Unfortunately it errors out and gives me an error to troubleshoot the play store.

Message is “can’t install Tablo - try again and if it still does not work see common ways to fix the problem”

I can install other apps no problem. Any ideas?

Thank You!

Is your Tablo a Gen 4 or is it an earlier model?

For what it’s worth, I am able to install and run the Gen 4 Tablo app on my Sony BRAVIA 4K VH2. It’s running Android TV OS version 10 with patch level September 1, 2023. It runs nicely, I think.

Thanks for the help.bIt’s the newer white one. I just installed it yesterday.

The device is working great on my fire tv. But my main use case was for the Sony in our family room as this seems like a wife friendly solution!

I tried installing other apps just to make sure nothing was broken with my play account. Everything else installs fine apart from the Tablo app.

Things to try…

Force quit the Google Play store app and clear cache.

Force quit it and choose that data, reboot.

Edit: changed a typo so the that it made sense and others could follow this easier on the future.

Thanks for the ideas. I tried that and still have the same issue.

Have you had any luck trying anything from safe mode?

All the other apps install fine. It’s just Tablo for some reason. But will check it out and see if safe mode makes a difference

One thing I’m wondering is if the Tablo app is confusing the app store. Out of all my devices, only two have been able to upgrade to 1.1.5. So maybe Google isn’t sure which one to push?

Honestly, I have no idea… Something seems strange though!

But if I’m reading your thoughts, it will download but not install? Out of curiosity, how full is your TV’s storage? You could try clearing the storage cache…

Just spitting out ideas. I’m glad your willing to try so many different things!

Just to confirm others are running this fine on Sony TVs? Support are saying I need to have a streaming device connected to the TV.

It’s possible that Tablo Support thinks that you’re using a Sony TV that doesn’t have Google or Android built in.

BUT… it might be worth spending $20 at Walmart to pick up their onn 4k box. It’s not a bad product and the price is right. Especially if you’re only going to need it for the TabloTV app…

How was your TV’s disk space when you checked it out? Were you able to clear out some extra cache from the storage options menu?

Today is the first day I was offered the new 1.1.5 android/fire app for any of my devices. (One two days ago, but I don’t use it to watch TV).

I’m still baffled why this is happening. I take it that Safe Mode did nothing to help…

If nothing else, I would check the support pages for your model of TV and see if any other users have had an issue installing certain apps on their system and what solutions they might have come up

As I wrote earlier, I run the Tablo app (Gen 4) on my Sony Google TV. It installed easily and runs well. I wish I could offer help with your issue.

Make sure you have enough space for the app. You might try removing one or two apps and trying again.

Tried deleting apps and installing other apps (all works no problem) i just can’t install the Tablo app

Are you installing the correct app?

There should be 2 apps available, one for the legacy Tablos and one for the new 4th gen Tablo.

Ok managed to fix it.

I had to go to look at running apps and clear the cache and data for each service related to the play store (there are more than one). Rebooted the TV and then it worked!

Tablo support were no help. The person working with me said it would not work and i needed to connect an external streaming device to make it work. Then just ghosted me!

I almost returned it but thanks to the help here i knew it should work!


I think if I had worded my instructions properly, you might have been able to get it up and running sooner! Sorry about that.

You may not have enough storage space for the app. Go to settings on your tv and delete the demo videos or apps you no longer need. It will take some navigating through some of the settings but it is worth the effort. Careful NOT to delete system files or apps needed to operate the tv!