Some help for double NAT situation

I would like to provide information on resolving double Nat issue with Tablo.
My Tablo is connect to my Apple Time Capsule router as everything else in my house.
My internet provider using DSL provided me a modem that can not disable NAT. My Time capsule is the only connection on the lan of the ISP router. The solution is to use a reserve IP address for the second router, in my case the Time Capsule , in the ISP router.
Then port forward on the first router (The ISP’s one) TCP 20120 to 21021 to the reserve address. On the second router (where Tablo is connected) port forward 21021 to 8887 and 21020 to 80.

Voila

Seems simple but It took me several iteration to get it right.

Hope this will be useful to the community

Why didn’t you just put the TC in bridge mode?

https://www.macobserver.com/tmo/answers/how-to-add-a-time-capsule-or-airport-extreme-to-an-existing-network-with-br

1 Like

yes, it works well. I turned off the radio on my router and put my Airport Extreme in bridge mode and everything has been working well for 2.5 yrs.

every thing is Apple at home and i like how simple it is with the time capsule as the central router. (Apple TV Home Kit Airplay back up etc)

The article talks about putting the Apple TC in bridge modem, but why not put the ISP modem in bridge mode?

Putting your ISP modem in bridge mode still allows you to use the Apple device as your main router. Bridge mode turns off all the router features of the modem and lets it act as a true modem only.

This is the easiest fix.

I totally agree with you but my ISP modem can not disable NAT even in bridge mode.

So the double port forwarding was the second best solution and I posted it to help other people in my predicament.

1 Like

Are you on AT&T? If so, go into the gateway (http://192.168.1.254) and set up the second router to be DMZ+. Then you can do port forwarding from the second router no problem.

Yes, I agree with you, but CenturyLink will not allow a user to put the modem in bridge mode…so I just turn off the radio and put Airport Extreme in bridge mode to avoid double NAT which can be nasty.

1 Like

They don’t offer a DMZ option on the modem? I’m pretty surprised. I’m in a similar boat with AT&T. I was doing the router in AP mode (similar to bridge mode) for a while but noticing bad performance on DNS resolution. AT&T doesn’t let you change the DNS on their router’s DHCP server.

So I switched back to double NAT with a DMZ+ so that I could use Google public DNS.

Thanks jus had to do this with today when I hooked my Ooma up to my modem.

I hate when ISPs do this, I have gone as far as to load 3rd party firmware on my modem to enable the bridge mode. I don’t like the ISP locked down firmware versions.

I’m getting my own modem as soon as I can. I just took my cable boxes back to Comcast tonight and the number port completed today for the ooma service.

I go to hook up ooma to the phone and nothing. Call them and they were not too sharp, buttttt, I was able to figure it was the modem and the ports.

Called Comcast support and took a look. Sure enough, I was not even getting the right download speeds because of the modem. And he said he was seeing a lot of sw errors. Henworked his magic and things are running great right now. I just have to find a modem that will do voice and data and work with Comcast.

After laying out my cord cutting expenses, I need to fond a deal. The only ne modem I know for sure that would work is $200 dollars at Best Buy.

I’d like to find one cheaper if I can. So it’s sale shopping and internet buy alerts…

Old thread, but replying to note that the OPs suggestion worked great for me. Bridging isn’t an option (ISP won’t budge) and IP Passthrough had issues (kept hanging at IP expiration from ISPs DHCP) so double NAT is only option.