[solved] Ports forwarded, Tablo can't make it work

I’m using a custom home NAT solution and for unrelated reasons, I’m not running with UPnP active.  Tablo complains about this:

Alright, no problem, I’ve added a NAT redirect for the requested ports:

# ipnat -l |grep
rdr wm0 port 21080 -> port 80 tcp/udp
rdr wm0 port 21081 -> port 443 tcp/udp
rdr wm0 port 21082 -> port 8887 tcp/udp

Let me stop here to specify that the above lines are the NAT rules.  wm0 is my external adapter.  What follows are the active NAT mappings after loading up the settings app and clicking “Re-Test Port Mapping” (with my IP sanitized)

RDR    443   <- -> 71.235.xxx.xxx  21081 [ 44741]
RDR    8887  <- -> 71.235.xxx.xxx  21082 [ 36321]
RDR    80    <- -> 71.235.xxx.xxx  21080 [ 60928]
MAP    60425 <- -> 71.235.xxx.xxx  35817 [ 443]
MAP    60424 <- -> 71.235.xxx.xxx  36297 [ 443]
MAP    123   <- -> 71.235.xxx.xxx  37995 [ 123]
MAP    123   <- -> 71.235.xxx.xxx  30491 [ 123]
MAP    123   <- -> 71.235.xxx.xxx  30324 [ 123]
MAP    123   <- -> 71.235.xxx.xxx  36419 [ 123]

Note that the redirects are present and match the requested ports.  From where I’m sitting, the configuration at the router is A-OK.

Still, Tablo insists that the mappings are broken.  The one exception, I might add, is port 443, which was green even before I added the port maps to my NAT config.

I feel I should mention that the Tablo has acted strangely ever since I plugged it in on my network.  It seems to frequently be confused about its own address, and it gave me trouble during activation.  Still, it can stream just fine from within my network.

Just to confirm that the port forwards do work, I use a browser from outside my network to access the public port for private port 80.  As expected, the Tablo responded with the “Nuvyyo Tablo Server” blank page.

The red exclamation means the port is either not forwarded correctly or forwarded to a port that doesn’t give the correct response when queried.


Have you actually tried using your phone or tablet remotely with the Tablo app? I occasionally get the port forwarding msg from the Tablo but “Tablo Connect” always works as I know the ports are forwarded correctly.

I believe I may have solved my own problem.  I think my firewall rules were interfering.

Yup, seems to be working now.

For the sake of posterity, and in the extremely unlikely event that someone else is using BSD ipfilter for NAT on their network, here is the firewall rules

pass in quick on wm0 proto tcp from any to any port = 21080 flags S keep state
pass in quick on wm0 proto tcp from any to any port = 21081 flags S keep state
pass in quick on wm0 proto tcp from any to any port = 21082 flags S keep state

@dhowland Glad to hear that you’re up and running - sorry I didn’t see this sooner! Give us a shout directly if you need anything else.

I’ve got this exact same problem.  For all intents and purposes, the ports are forwarded correctly but it keeps coming up with that "needs manual configuration"

WD Mynet 750 router running through a 2 Wire modem.


That is likely your problem. Most 2Wire Modems are not just only modems - they are modem plus router combos. Thus you need to put the modem in bridge mode.

The routers do not like bridge mode…  At all.  I’ll just have to suffer until the network in my area upgrades.  I had no issues when I was on fibre.


We can solve your problem. On the 2Wire DMZ the IP that your WD router is assigned.

Looks like I have a project for tomorrow.  

I seriously can’t bridge the routers.  Bridge mode crashes the WD router.  Part of the issue with bridging is that this router is firmwared up to bridge with SaskTel Max, as I’m not the only one having issues with port forwarding, and the workarounds don’t work because of the original intended purpose.

The SaskTel firmware likely has the bridge mode disabled. You could unlock it with another firmware. What’s the exact model?

You don’t put the WD router in bridge mode, you set it to PPPOE for the WAN connection.

Got it!  The 2 Wire was the issue.  When I tried this earlier this year and gave up, I set a bunch of permissions that I didn’t delete that were causing a conflict.  Huzzah! Remote access.


How did you fix it? For others reading this thread in the future.

There was a port forwarding conflict.  I had the Tablo setup on the 2 Wire for portforwarding, and not the MyNet 750.  I forwarded the Tablo on the MyNet 750 and then I forwarded the MyNet 750 on the 2 Wire with same ports opened.  Don’t know why it worked, but there it is.

http://www.canyouseeme.org/ to check for open ports enter 80 for example