Setup and First Impressions

Hello! I just received my device today and I wanted to give my feedback. I managed to work through my issue, but I didn’t see a “bug report” section to report in, so this seemed like the next logical place. (some of this probably belongs in the Feature Requests section)

My main use for this is to provide OTA to my ROKU. I’d been holding out waiting for Aereo to come to Charlotte, but it looks like out of luck now. 

Unboxing and plugging into my network and hard drive was pretty painless. I’d reviewed the list of approved hard drives on the forum and purchased one accordingly. 

After hooking everything up (wired connection to Tablo and ROKU), I tried to set up the Tablo using the ROKU. It (and the paper I didn’t read) told me that I needed to use my iPad or Android tablet. Of course, I didn’t read that closely either, so I first tried to download the app onto my Nexus 4 phone. When Google Play told me it wasn’t compatible, I realized it was a tablet-only app, so I got out my Toshiba Thrive. Unfortunately, it’s a few years old, and the Android App wasn’t supported on it either. 

I then went to the web app. The web app seemed to detect my Tablo. It first asked me if I wanted to format the hard drive. I then got to the point where I needed to enter my zip code. After entering my zip code, it hung up “verifying” the zip code. I waited several minutes, thinking that maybe it was scanning the channels also, but eventually I refreshed my browser and started over. I tried it this way 3 or 4 times and it hung up every time.

To get it set up, eventually I borrowed my girlfriend’s Android tablet. Hers is newer and the Tablo app worked just fine on it. The first thing it asked me was to update the Tablo software. (Why didn’t the web app ask me this?) Once it updated, it again asked me to format the hard drive, and then I input my zip code. It was nearly instant when it moved on to the channel scan. After getting past the zip code hurdle, setup was a breeze. 

Bug 1) Wired tablo/wired computer, web app repeatedly hung up verifying my zip code during the setup process. However, now that I’m writing this out, I was using Chromium on Ubuntu. I’m not sure if the fact that I wasn’t using Windows or Mac makes a difference. I never tried it under Windows. Here’s my specific Chromium version information: Version 34.0.1847.116 Ubuntu 13.10 (260972).

Bug 2) The Android app seems to crash a lot. 

Suggestion 1) Put a list of “approved”/“confirmed working” hard drives somewhere easy to locate. Don’t make people have to dig into the forums to figure out what to purchase. Somewhere I thought I’d read that it requires a USB 3.0, so I actually purchased a new hard drive for Tablo. If I could’ve used my 2.0 I would have preferred that. 

Suggestion 2) I believe I saw in the forums that you’re working on a grid schedule view in the ROKU app. If this doesn’t come to fruition, I would like to see the show episode information in the Live TV section somewhere before actually tuning the channel. Rather than showing the picture on the side today, if I could see the episode information that’d be a better use of space. :) 

Final thoughts: Overall I love the concept and the current functionality. As I said, I bought it for the ROKU integration, but the ability to watch on my Android tablet is a nice addition. Every new device has some bugs and growing pains, and I don’t personally mind them as long as the core functionality is there. Keep pressing forward! This is a fantastic product overall, and I wish you all success. 

@sixy - Thanks for your feedback! We’ll take a look at your issues with Ubuntu and we’ll be issuing an update to the Android app shortly to add more stability. 

We’re also planning lots of updates to the Roku app but that is good feedback on the use of space in the LiveTV area. We might be able to do that in the meantime before we get to the grid which will require a significant amount of effort.

As for hard drives, we’re working on an update to be able to support more drives out of the box but in the meantime we’ve added links to the hard drive post in several of the FAQs on the main site as well as in the confirmation email when you purchase Tablo from our site. 

I just tried to set up a Dual Lite using Windows 10 and had the same problem with the postal code. The setup program could not “verify” ANY postal code. After reading this thread, I used my iPhone and it worked just fine. NOT a great first impression:(