Security Certificate error

When I attempt to go to using Chrome, I get:

Your connection is not private

Attackers might be trying to steal your information from (for example, passwords, messages, or credit cards). NET::ERR_CERT_COMMON_NAME_INVALID

I’ve rebooted the Tablo. What do I do now? I’ve tried IE and get a similar error.

The correct address is

That’s probably why you’re getting that message.

I omitted a dot in my first post.
When I try, it is redirected to and I get the error message.

That’s strange. works for me and gives me the security warning.

Hmmm. IE started to work all of a sudden. I cleared cache and history in Chrome and now it works. Strange.

I see the same errors. Looks like their certificate is incorrect.

When I type in just in my Chrome browser, it loads

Do you have some specific settings in your Chrome to always load SSL websites?

This is a good thread for @TabloTV to watch, SSL should be the default for with all the hacking nowadays why tell people your ports and IPs to let them try???

I’m personally only speaking of the https site. I checked it in Firefox and IE. Firefox wouldn’t even let me see the certificate. IE warns the cert is issued to * and the name does not match the site name.

That is amazon and is what Tablo uses for

So, when I go to, it’s not just going directly to my tablo device in my house and launching the interface? It’s going out to Amazon, then back to my house? Or is it accessing a copy of my settings and content listing out on a database stored on Amazon? What exactly is going on there?

It goes out for some basic info a very small packet and then connects locally.