Scheduled record time one hour later than when program airs

All of my scheduled record times show up as an hour later than when the program actually airs. For example, 10:00 PM news is scheduled to record at 11:00 PM. Still seems to record at the right time.

Not sure if this is your problem, but make sure the timezone setting on the playback device is correct for your area. I know on Fire TV, for example, if the timezone in the Fire TV settings is wrong, Tablo will provide incorrect results for your timezone.


Same type of issue. I am located in AZ, and the guide is correct. When I record a program scheduled for 9 PM, it records correctly, but the recording info says it was recorded 1 hour earlier (8 PM).

@tld @TerrainCrawler

This is the result of a discrepancy between the Tablo’s time zone and your local time zone. The Tablo grabs its time zone information from the device you use to run a channel scan on the Tablo.

Make sure your device(s) all have the right time zone information on them, and then open up the Tablo app and run a new channel scan: Settings > Edit channel lineup > Rescan> Add to guide.

Keep in mind that if you have any kind of VPN or IP altering/masking service, this will interfere with the time zone being set. If you continue to have issues, set us a ticket and we’ll take care of you.

I just noticed I’m having the same problem. Shows are recorded on time but the time on the schedule and recording are off an hour. All my devices are set right. I too am in Arizona, I wonder if it’s a glitch because we don’t use daylight savings. In the summer during daylight savings we’re on the same time as Pacific time, which is an hour different from Mountain time, our regular time off daylight savings. Was this time difference taken into consideration in the firmware? A lot of devices have time zone settings that will account for that. For example, Windows OS allows you to specifically use Arizona time rather than general Mountain or Pacific time.

@dhanger The Tablo leaves all of the time zone decision making to the device that runs the channel scan - so this shouldn’t be a problem. If you’re still having issues, please feel free to send us a ticket and we can fix this up for you.

I am in AZ and this is happening to me too. The timezone settings are fine on my laptop. I am just using the tablo webpage for the setup. This seems to be a common thing from looking at the community posts. Any suggestions?

Is the laptop set to automatically adjust for daylight savings?

Yup, just send support a ticket and they’ll fix it for you. That’s what I did, and everything’s fine now. I had everything set right on every device and nothing would fix it, it had to be done by them logging into the Tablo.

No, There is no daylight savings in AZ. Our time does not change.

Good to know.