Same calendar day manual scheduling problem

I just purchased a 2 tuner Tablo via ebay, and have so far found it to work quite well. I connected a 1TB WD Passport with no problems, and was even pleased to see that a number of channels that my TV refused to tune come in crystal clear via the Tablo’s tuners (something I’d seen using a Hauppauge tuner as well). I haven’t yet created a subscription account to try the premium guide features, mainly because I wanted to see what the completely free version could manage, and that’s where I hit a snag. I can happily schedule multiple recordings and see them show up in the “scheduled” tab, HOWEVER, if the program begins on the same calendar day it won’t be added. In other words, if it’s 5PM EST on 2015-07-15 and I try to manually schedule a program tha truns from 7-8PM EST on 2015-07-15, it doesn’t get added. If the program starts any time the next day or later, it’s fine. I’ve tried this for several different programs on 3 different channels, all of which have a strong signal. And in one of the cases, the program I was trying to tune an hour in the future (so, same calendar day) was also playing the next day and scheduled successfully, so it doesn’t seem like a problem with the program name or other metadata. I’ve confirmed this behavior happens whether using the iOS app or the webapp and Google Chrome.

My Tablo is running:
firmware 2.1.30 with HTML Application: 1.0.21-539

(it did do a firmware update as soon as I plugged it in, so I have no idea how long it had been out of use when I bought it). The seller was also on the pacific coast and I’m eastern, so I originally thought maybe it was a EST vs. PST difference, but it clearly has my zipcode so it should know where and when I am. I’ve tried a factory reset (holding the button for ~30 seconds through all kinds of light patterns) to see if it makes a difference, but sadly it doesn’t. I’m connected via ethernet, if that makes a difference.

Does anyone have suggestions as to what I should try next?

  1. Are you using the Chrome browser on your computer to access
  2. After you set up a manual recording for the same, can you see if it shows up on another device? Say an iPhone, iPad, or Android phone / tablet?
  3. I just set up a ‘Just Once’ recording for 30 minutes at 11 PM. It immediately showed up in my Scheduled section. I will let you know if it actually records tomorrow. It does not show up on the ‘Live TV’ grid as a time that’s being recorded.
  4. The process that I used to create a manual recording was: my to in Chrome, then click on the three horizontal bars icon as the top left of the scren, click on “Scheduled”, and then click on the “+” sign at the top right of the screen. How did you do it?

1 - Yes, chrome browser to

2 - It doesn’t show up on the iOS app or my Roku 3 (with either app)

3 - I don’t see an icon on the TV grid for the manually scheduled item on the live TV grid either.

4 - I went to the live TV grid, slid the slider left about 3 hours to the time when the program I wanted to record, clicked on the program name and it popped up a manual record dialog in a lightbox. This is apparently the default behavior when there is no subscription attached to the unit.

I’ve since activated a subscription, and now going to live TV grid view lets me click a “Rec” button for any highlighted item. In an hour I’ll know whether or not it will record same-day with the subscription enabled. If so, tomorrow I’ll detach the unit from the subscription and see if the original behavior returns, which would indicate the bug (if there is one) may be limited to the free listings only.


Ok, upon further inspection in the new Roku app, my time is wrong – in the top right corner it says 5:29AM, even though it’s 1:29AM Eastern time as I write this. I expect this is what is causing manually scheduled recordings to fail – everything I tried was less than 5 hours away, so if the internal clock is off by 5 hours, it would have thought the start time had passed already.

Is there some way to set the time manually, or override wherever it is getting it? I would have thought it simply figured it out based on the ZIP code.

1 Like

The ZIP code is just for the guide data. The Tablo’s time is set to the same time on the device you did the initial setup but it doesn’t always work.

Do the following steps:

  1. Make sure the device you’re using has the correct time and timezone.
  2. Do another channel scan by going to the Settings page, Edit Channel Lineup > Rescan > Add to guide
  3. Once this is done, reboot your Tablo by pressing and quickly releasing the blue reset button on the back of the box
  4. Once the blue LED is solid, your Tablo is connected.

Check if the time and timezone are correct.

You may have to do the above steps more than once.

The time that shows up on a device say a Roku or Fire TV is determined by the time zone set on that device.

Go to the Roku settings and see what the time zone is set at.

Ok, I confirmed my Roku didn’t have a timezone set (my router isn’t broadcasting the NTP data properly for some reason), so once I set it manually to US/Eastern the time did show up properly on the Tablo app. My initial setup was done from the iOS app, and my phone certainly has the right date/time/timezone info, but when I disconnected from the subscription service and tried a manual schedule, the original problem appeared again. I then reinstalled from the iOS app per sgnadeau’s suggestion and there was no change. This evening I will try reinstalling from the webapp (assuming that’s possible) to see if that makes a difference. Is there some advanced/secret menu where I can check things like the timezone on the Tablo, or an API I can use to make queries?

I just watched my manual recording for 11:00 PM to 11:30 PM that I set up at 10:30 PM last night, it all worked fine.

Except I have a subscription so I didn’t set up the manual recording by clicking from the Live TV grid. I did it as a I explained above.

You could try factory resetting your Tablo, and then setting it up from the website on a Chrome browser on a computer that has the correct time zone set. Or you could use the iPad app. I have never set up a Tablo from one of the Web apps (aka the iPhone app). The iPad app and the iPhone app are quite different.

I disconnected from my subscription and went to try a manual schedule again, and sure enough, if it was for the same day it would fail. I then did a factory reset and attempted to configure the unit from, but couldn’t get it to connect for some reason (even though my home network uses DHCP and my router has a hard-coded IP for the Tablo’s MAC). Configuring again from my iphone reproduced the original problem.

I’ve re-enabled the subscription since the device isn’t too useful to me without it, so I don’t really care about this issue anymore. But FWIW I’m 99% sure there is some kind of software bug in the non-subscription manual scheduling tool.

Thanks to all for your suggestions!

If there is a bug, you are the first one to notice it. I would suggest you submit a trouble ticket so that the Tablo folks can look at your logs,

@wbill3d That’s some interesting behaviour. We’ll be testing with this on our end - sorry that we didn’t get the chance to check this out while you were reproducing the problem.

If you run into something else in the future, shoot us a [ticket][1] right away and we can get a good look at things.