Roku will not connect to Tablo

Have a new Tablo Dual and Roku Ultra. Installation went without a problem. Using a Asus router, Tablo is connected by Ethernet and Roku connected over WiFi. Roku Tablo app can not find and connect to Tablo.

Have tried all the listed troubleshooting tips. Resets, reboots, power resets, uninstall/reinstall of all hardware and software. No errors I can see except Roku keeps coming back to the opening Tablo app screen when search for Tablo ends with no connection.

What else can I look for? Any help appreciated.

Have you tried connecting both via Wi-Fi (on the same band)?

1 Like

So you are saying to not use the Ethernet connection for the Tablo? I guess I could try that, but thought the Ethernet way was preferred.

Ethernet is and is where you will want to eventually wind up, but I think I would try it (making sure that both the Tablo and Roku are using wi-fi on the same band (either both on 2.4 or both on 5). If they then “see” each other, you could try going back to ethernet.

Note: The Roku does not currently support initial setup of your Tablo. You’ll need to complete this via one of our other apps (iOS, Android or web).

Note: The Roku does not currently support initial setup of your Tablo. You’ll need to complete this via one of our other apps (iOS, Android or web). For instructions on installing the Tablo app on your Roku device, click here.

https://support.tablotv.com/hc/en-us/search?utf8=✓&query=roku&commit=Search

Connect your Tablo to your home WiFi router via Ethernet (setup via WiFi is not supported and must be done via web or mobile apps)

Well that worked, putting both the Tablo and Roku on the same band. This gave me the clue I needed to figure out the problem. I had my Roku on a guest WiFi channel that had access to the rest of the LAN blocked, which of course included the Ethernet ports. So once that was enabled everything is working great. So thanks for helping me out.

1 Like

You should keep your guest WiFi network separate from your internal network. Did you change the WiFi connection on the Roku? I usually disable my guest WiFi network.

Yes, my Guest NW is separate, just didn’t think about that the Roku was on it and blocked from the Ethernet port the Tablo was on. Now everything is working perfectly.