Roku Ultra Problems

Good morning everyone. Got up this morning and turned on the Roku and started watching a local channel and in about 1 minutes it kicked back to the Roku main screen. I know this is a problem with the Tablo Gen 4 but my Ultra in kicking me out of all my apps. Will play about a minute and that is it. Was curious if anyone else is having this problem. Thanks

1 Like

Weird, this Roku is doing this with all your Apps.

Tried rebooting it? Confirm the firmware is updated?

1 Like

Yes I have done all those things and it is still doing it. It was working fine yesterday but this morning it went haywire

As @KimchiGUN asked, it’s doing this to all of your apps?

I know it’s likely not going to help, but have you tried the force cache reboot trick? (Doing this moderately quickly, Press Home 5x, Up, Rewind, Rewind, Fast Forward, Fast Forward and wait for it to scroll, freeze, then reboot.)

Couple quick questions in a row:
What Roku model are you using? What Roku version does it show? Do you know if it’s upgraded recently?

1 Like

I have three Roku TV’s, one TCL, one Westinghouse, and one Insignia.
All three run perfectly for three, maybe four minutes, then the app closes and the TV returns to the
Home screen, or reboots the TV.
All three do this like clockwork. Clearly the app is the issue. What can we do about it?

1 Like


Yes, there are some issues with Rokus right now and the Tablo app is affected by this. If you’re having this problem while watching live TV, I would first try to pause it for 30s or so and see if you have better results. (On one of my Rokus I have to let it play for a bit and then use the Jump Back button since the Play/Pause won’t always work in Tablo’s live TV mode.)

Most of us have found this to be the best workaround right now and from Tablo’s last support response here, they’ve been in contact with Roku and are trying to get them to fix their end.

I know it’s not the perfect solution you’re looking for, but TBH, I think there needs to be a larger buffer set for live TV on the Tablo app – it has to record it to your drive and then stream it, so depending on your network or drive speed, it can use all the help you’re willing to give it.


Thank you!

I will give this a try when I get home … I don’t see any buffering when playing, but at this point, I’ll try anything!

I had this problem with one of my Roku Ultras happening on ALL apps. Simple power down, wait one minute and then power back on solved the problem.

The Tablo app problem is a different thing and appears to have a temporary fix imminent with a permanent fix (hopefully) by Roku.