Roku/Tablo does not recognize subscription

I have been using my new Tablo with my Roku but am suddenly unable to record programs. Quite sure this is because my trial subscription had ended, so I purchased a subscription, but the Roku is not recognizing it and I am still unable to record.

I have unplugged everything and restarted, but the Tablo channel still shows that I do not have a subscription and offers no option to change this. The only thing I can do is “check for updates,” but when I do this it just shows that the firmware is up to date and that’s it. Just need to know how to get this thing to recognize the subscription I just paid for! What am I missing?

I tried calling the Tablo support numbers but they appear to be out of order. This is not my machine but my mom’s, and neither of us is especially tech savvy so this whole transition has not been easy, to say the least, and we are both losing patience. Considering a move to Tivo instead, and just getting rid of this, if we can’t resolve this issue quickly. Super disappointed.

Any suggestions would be greatly appreciated!

Did you associate your Tablo with your subscription?

What is your subscription’s status when you log in to ?

Yes, I did associate the Tablo with the account, and the status is paid.

In another thread, someone had a similar issue and Tablo Support mentioned that it could take a few hours for the Tablo to recognize the subscription.

Have you tried connecting to the Tablo with the web app at and clicking the Refresh button in the settings page?

Maybe this could speed up that process.

I did try that earlier but nothing changed. A while after we paid for her subscription, my mom received an email from Tablo to confirm her account. I just tried clicking the link it included and got this error:

Activation Failed
The activation token used is no longer valid. Please contact us if you are unable to create a new account.

I have absolutely no idea what this means; there was no mention of a “token” when we subscribed her and I’ve seen no reference to it in any literature or in settings for Roku or Tablo - But perhaps this is the problem? If so, how do I rectify this?

You can only activate an account once, so that link becomes invalid after the first use.

Ah, okay, thanks for answering that!

Tablo/Roku still does not recognize her subscription. Is there any way to force it to refresh or otherwise connect with her account?

Go to the following web address, and log in:

It will display your subscriptions, along with associated Tablos for each subscription type.
What does yours show?

Update: Tablo/Roku is now recognizing her subscription and recording again! I guess it just took two days for the system to recognize the subscription.

Still not feeling great about this system’s user-friendliness, but hopeful that it will improve with future updates. Thanks to you both for your help!