Roku playback of surround recordings


#1

So I have a 2 Roku’s, Fire TV, and FireStick. I enabled surround. I’m having an issue with playback of recordings on the Roku’s. It works fine on my Amazon equipment but my two Roku’s will start to load the recording and then kick back to the main watch now screen of that recording. Is this related to the Roku app not being updated. I also have no issues playing back on my iOS devices.


#2

After tinkering for a few hours I figured it out. I forced my Roku’s from Stero to Dolby and the recordings play now.


#3

Also works it you set your audio channels to Auto on the Roku system settings.


#4

I have 2 Rokus as well and ever since the surround sound update and me enabling surround sound for my tablo recordings, my recordings are not being played back on my Roku devices. They playback fine on my iOS devices.

In my Roku, I have my Audio settings for HDMI as ‘Auto Detect’ and based on that my ‘Audio mode’ goes to ‘Auto (Stereo)’

If I select HDMI as ‘Dolby D+, DTS’, the Audio mode then goes to ‘Auto (Dolby, D+, DTS)’. I can then playback my Tablo recordings on my Roku and hear audio fine. The problem is that many of my movies on Plex then stop having their audio played back as well as my Amazon Prime Video app on the Roku.

I don’t want to have to change these settings all the time based on if I am using plex, amazon prime, or my tablo. Thoughts?


#5

Thank you for posting this. It fixed my problem to change HDMI to Dolby Digital. All my other channels seem to be playing fine. It does not work on my Roku to set it to Auto.


#6

Set the HDMI setting go “Dolby D” only. Your TV can’t play DTS.


#7

I spoke too soon. My bedroom TV gives me an error “your Roku is not connected to a device that supports surround sound.” It is an older plasma tv. I turned surround sound off on Tablo settings and tried HDMI Dolby on the Roku and nothing works.


#8

If you turn surround sound off on the Tablo, the Roku needs to be set to either Auto or Stereo, not Dolby.

Think of the Roku as a pass through device. It passes the audio through to another device that needs to decode it. It can pass through stereo or Dolby Digital. But it’s up to the next device down the chain to decode it (like an AVR or a TV)


#9

And if a recording is created with Surround Sound it won’t revert back to stereo sound when the toggle is switched off.


#10

This does not work. On my older stereo TV, I have the Tablo surround sound set to off, and the Roku set to audio and HDMI Auto as you suggest. Still gives me the same error message.


#11

Mine took some time to revert back to stereo. I did a reboot to make sure it was back to stereo.


#12

The Tablo surround sound setting is a global one for all devices.
It’s either on for all, or off for all.

The surround sound setting is not instantaneous, in some cases.
Channels will hang on to the previous surround sound setting, if they are tuned in before you changed the surround sound setting.

I would reboot the Tablo after you change the surround sound setting just to make sure all tuners are released, and will execute the new setting.