Roku not playing TABLO signal

Hi, I have a Roku Premiere and a Roku Ultra, few weeks ago they stopped playing video from the Tablo. It will appear like the app is running in the Roku, I can get in and see the menus, but when I select to view a channel or a recording the screen just shows the Channel title in the top, the loading circle in the center and the “Select Channel Message” in the bottom, and eventually the Roku’s will pop up the Screen Saver image. When clicking the Roku control, I’m back to the black screen. From this screen I can change to a different channel if I want to and this will change the Channel Title at the top, but besides the title, the “Loading” circle and the “Change Channel” text the rest of the screen remains black always. Besides the problem with the TabloTV app, the Rokus work (all other Roku channels and apps work).

I have a Roku Streaming Stick+, and it works there with no problem. I have also an intelligent Sony TV (Android) in which I downloaded the TABLO App, and in this TV the app runs without a hitch (I can see the TV signal and recordings without problem). I also can operate and see normally the Tablo video signal in my computer (Windows 10 using the website my.tablotv.com) and my cell phone (Apple Iphone with TabloTV app)

Why can I see video signal in the SONY TV, Roku Stick, computer and Iphone and I cannot in the Roku Ultra and Premiere? Is there a problem with the TabloTV Roku App?

(NOTE: I gave feedback today to Roku indicating that I have no video signal from the channel in both Roku systems)

My systems:
Tablo Quad Model TQNS4B-020CN
Tablo Firmware: 2.2.42
Internet Ethernet connection, wireless distribution.

Roku Ultra:

  • TabloTV Channel Version 3.0.0 (I uninstalled and reinstalled it today)
  • Roku Model 4660X
  • Roku Software Version 11.0.0 Build 4193-46

Roku Premiere

  • TabloTV Channel Version 3.0.0
  • Roku Model 3920X
  • Roku Software Version 11.0.0 Build 4193-91

Roku Stick

  • TabloTV Channel Version 3.0.0
  • Roku Model 3810X
  • Roku Software Version 11.0.0 Build 4193-50

Iphone XR, TabloTV App version 2.4.0

Sony TV:
Model: Bravia 4K GB
Tablo TV App Version: 2.2.2

If you haven’t done so already try uninstalling/reinstalling the Tablo app on one of the problem Rokus.

I’ve used Rokus with my Tablo for many years and haven’t seen anything like that before.

Thanks. I already did that on the Ultra, no changes.

Grasping at straws here, maybe try a different Ethernet cable or different port.

Thanks again, but it won’ t explain why it works with the Roku Stick, the Sony TV, the computer and the phone… there should be something else (at least the software versions in the phone and TV are different, no explanation for the Roku Stick, besides it is the oldest Roku I have).

Still if I find another new Cable I might try and see. I’ll post results if I do it.

@przci This is a VERY strange case.

It’s difficult to know exactly what’s happening without diving deep into the Roku but it seems like the built-in Roku player (which we use to display video) isn’t working. The overlays in the Tablo app seem to work based on the fact that you can see the channel name and the Quick Channel Select option.

(The reason why other apps are working is likely because they use custom players that are part of the overall app package, and not the Roku OS.)

Can you try fully powering down the Roku (unplugging it from the wall, waiting a minute and then plugging it back in)?

We’ll see if that gets your Roku to stop forgetting it’s there to play video.

Thank you for the recommendation, I applied it with mixed success.

I unplugged the Roku Ultra for 10 min, and plugged it again; now it works! (yey)
I unplugged the Roku Premiere for the same time, still does not work…

I will leave the Roku Premiere unplugged (both power and video) for one day and try again. I’ll post results whenever I have a chance (next few days will be busy for me)

Regards

Don’t know if this will help you, but…

If my router is rebooted, my Rokus will not see the Tablos, until the Tablos are power cycled off, and back on.

Glad to hear we’ve got a 50% success rate!

If the Premiere doesn’t get with the program after its time out, maybe try a factory reset (of the Roku)?

Just to clarify, try a factory reset of the Roku, not your Tablo.

Indeed.

Hi again. I left the Roku Premiere unplugged for 4 days and tried again, now it works. All Rokus are working now with the Tablo. Thanks for all the help!

1 Like

FYI, my Ultra just updated to v11.5. Hope it doesn’t introduce too many new issues. :grimacing: