Roku media player won't play videos created with tablo ripper

For some reason videos created using the tablo ripper play fine on my computer but will not play via roku media player from usb hd attached directly to tv or through usb on router. Help!

So there’s nothing wrong with the mp4’s…
I’d suggest you try support.roku.com (?) or maybe community.roku.com (?)

What does “will not play” mean? Does it mean you get a message, or it tries to load but never gets to starting to play, or starts to play and continuously buffers(loading), or?

There are many different models of Roku. Each with different performance characteristics which can drastically affect the Roku media player.

I have 2 roku tvs and one older roku stick. Media player recognizes the files but when I select play it says retrieving for about 30 seconds and then sends me back to the list of videos. Other .mp4 videos copied from my PC play fine just not the ones created in tablo ripper.

Is it possible that your Roku’s don’t have read permission for the directory your Tablo Ripper files are stored in?

The Roku media play has a certain amount of video it needs to buffer to play.

If it can’t get enough good data in the correct amount of time it barfs.

And not all media players are the same. I suspect the Roku media plays was designed for local SD cards.

My Roku 3 media player struggles with my hdhomerun. And even my ultra does. And if they are going to barf it’s at around 20-30 seconds.

But the hdhomerun app has no problems.

Have you considered using Plex? I run it on my PC pointing to my video file library and use the Plex app on Roku. Works pretty well.

1 Like

Have you tried a system restart? From the main menu go to settings…system…system restart. As mentioned there are minor menu differences with the different Roku models so yours may look a bit different. On my TCL Roku TV I believe its settings…system…power…system restart.
Sometimes my TV will show the directory structure but can’t find the videos. Knock on wood a restart fixes that.