Roku black screen issues

I’m sure this is a Roku issue, but you guys are always so helpful, I wondered if anyone has a similar experience and maybe a fix.

Everything was going along fine until maybe 6 months ago (guessing). Sometimes when I exit the Tablo (or any other) app, OR just exiting the program I’m watching, the screen goes black. I have to either hit the home button or power off/on the TV to get back to the Roku menu, then re-enter the app I’m using. I believe this is a Roku OS issue as I’m experiencing this on a Roku soundbar, a Roku TCL TV and a stand alone Roku stick. My son, who lives elsewhere, is also seeing this on his Roku stick.

It’s becoming more frequent and really getting annoying. To the point of me thinking about replacing all my Rokus with a different streamer, but I like the simplicity of the Roku menu. Any ideas?

I am seeing the same, also with increasing frequency. I think this is only happening on my TCL, or at least that’s where I really notice the problem. I have several other Rokus that may not be affected. I grumble, hit the home button, and relaunch the legacy Tablo app. Yes, it’s annoying.

Yes, I am seeing the same thing. Seems to be a Roku problem because when I quit and restart the Roku is restarting and then everything is OK for a time. I have the latest Roku and software. My guess is that it is a bug hole in the Roku software???

It’s a known issue with OS 12 and some apps. I sometimes run into it with YouTube. Just hit the Home button if it doesn’t exit after a few seconds. No need to reboot.
There is an OS12. 5 rolling out. Hopefully that may fix the bug.

Thanks for the replies. I did a online search for this topic and didn’t find much of anything current. One would think there would be more out there if it’s this widespread. Hope the 12.5 fixes it, it’s just annoying as all get out and getting worse.

I do the same. Haven’t noticed an increase as others have mentioned however…

My Roku Ultra is on 12.5.0-4165 and the good news is that the black screen hasn’t appeared in my limited testing.

Unfortunately 12.5 introduced an annoying delay on app startup (legacy). Sometimes the app will start very quickly as normal, next time it hangs for 4 or 5 seconds, and a few times the Tablo was not found. After the app is open all seems to work ok.

Great, fix one thing break another. Seems to be the trend at Roku, fix what isn’t broken. I got tired of waiting for them to do anything and have now switched to Google TV 4K. Seems quicker than Roku, interface is a little busy, but you can switch to just apps view and that cleans things up. I think it also runs/loads apps a little quicker, depending on the app.
One weird thing… in getting the Tablo app from the playstore, I saw two and downloaded the one marked Tablo TV. When I ran it, it could not find my tablos. So I went and downloaded the ‘legacy tablo’ app and it works fine.

The Tablo app with the icon with the blue background is strictly for the new 2-tuner 4th gen Tablo at the moment so the only app that will work on the non 4th gen units at the moment is the Legacy Tablo app with the white background.

A firmware update to allow the non 4th gen units to use the new Tablo app if desired (and with caveats) is supposed to be coming later this year…

For more details…

My Ultra is now on 12.5.0-4167-46 which seems to have solved the slow app startup problem. Black screen still gone!

I am still waiting for all four Roku devices to pickup OS 12.5. Hopefully, the black screen and the weird flashing in the user interface stops, but I’m not holding my breath.