Roku app incorrectly displays number of recordings

I am having a new issue with my Tablo and the Roku app. This problem does not show up on either of my iPads.

I have a 4 channel Tablo with a hard drive connected to record shows. It has been working fairly well with few issues but recently one show displays a number of episodes in the corner of the image under “Recordings” but the number is incorrect. It currently shows 9 episodes when really they have all been deleted and there are 0. When it does record another episode the count goes up correctly, meaning it would go from 9-10 but if I erase the one added episode the count stays at 9.

I have restarted the Tablo.
I have rebooted the hard drive.
I have accessed the recordings on other devices and am not having this issue.
I removed the Tablo Preview channel from my Roku and then added it back in.

None of these things have worked. Can anyone help me out with some ideas of what to do?

Thanks in advance!

Delete the Channel off the Roku, reboot the Roku, re-install the channel.

Thanks for the suggestion. This did not work.

What does the original Tablo channel say? Not the Preview version.

Excellent idea. There were some episodes displayed there that were not displayed on the preview version. I deleted them. Now the Preview version shows 2 but none are really there, the original version never showed how many episodes like the Preview shows but it shows a thumbnail as if there are episodes. When I click on the thumbnail and try to display the episodes it just reverts to the main menu. Hmmmmmm

I think the key question here is what Roku model do you have?

These channels were ideally designed for the Roku 3 Model 4200 or newer. Are you using an older Roku by chance?

It is a Roku model 4200X-Roku 3 software version 6.2 build 3672

@Spiderterp - The Roku app refreshes the page when you leave a page go somewhere else and then re-enter it. It will not refresh on the fly so this may be why you’re seeing this.

Next time you delete something, navigate away from the page and then back and see if the number is correct.

Thanks for the suggestion. I have done that a bunch of times. We are constantly going in and out because we also access Hulu plus and Netflix. This problem has existed for a couple of weeks now. I have gone in and out, rebooted the roku, rebooted the tablo, rebooted the hard drive.

@Spiderterp - We weren’t able to reproduce this here this morning but our Roku experts say that it is possible this could happen.

The reason for this is that right now Tablo’s Roku app has one-way communication with the server. When we do a delete, we manually refresh the lists of shows to force a screen update with current data. However, if the user presses delete and then backs out of the screen quickly, the update may not happen.

We do have a future server + Roku app release that will enable full two-way communication. Once that is in place, this will no longer occur.

So in the meantime, take a minute to pause between deletes on Roku and/or use a Tablo app on a platform that does support two-way communication to clean up your drive (basically anything BUT Roku).

1 Like

This is probably exactly what happened. I do have a habit of doing that. Thanks for troubleshooting this, at least now even though it will still display until the new app is available I know what the problem is. Thanks again.

Have kind-of the same problem here , i have three thumbnails of shows that show on recordings page and recordings have been deleted but thumbnails still show up. We should not have to remove the app or reboot or restart . Please fix this problem. I am sure this will start happening to others ,

Update , make that four thumbnails after tonight , tried deleting Gotham which recording is gone but thumbnail still there