Roku App "Checking Connection"

I just got a new LED TV to replace one that burned out in our guest room. I am trying to watch Tablo on the Roku connected to this TV but when I select a show from the guide and click watch it starts to buffer and then goes to a white screen that says “Checking Connection” and then goes back to the watch/record event screen for that show. This happens on all channels and recordings. It seems to connect fine to the tablo though and will pull the guide and recording list. Any suggestions? This roku is in the room above where my router is located and plays all other streaming channels fine (Netflix, SlingTV, etc).

Roku HD 2500X
SW V7.0 build 9021

xxx ccc xxxxx

1 Like

It sounds like the TV firmware is checking the Copy Protection of the show before playing it thru the HDMI. It could be fixed with a firmware update to the tv as philsoft suggested. You might want to try a different HDMI cable from ROKU to TV for kicks.
Good Luck
Doni :smile:

Thanks for the replies. I can’t find a firmware update for the TV. This is a cheap $80 24" LG black Friday deal. I tried swapping out the HDMI cable and I got a channel to play just once and then nothing on any others or recordings. I have 3 other Rokus in the house and haven’t seen this on any of them. I even tried just connecting this roku via composite cable and I get the same issue. I’ll try it on another TV.

OK, I swapped the Roku out with the one in my living room that we use the most and I get the same issue. I’m thinking there may be a disconnect between this roku model, the new tablo app, and my tablo. My tablo is still on firmware 2.2.6 and still waiting on the 2.2.8 update. Maybe that will help.

@Prowler01 - I believe that’s a Roku LT which is an older model. Can you try loading the legacy channel to see if you’re able to use that? You’ll need to load it using your online Roku account. Use the channel code: tablolegacy

I have a Roku 2500 also and it does the same as @Prowler01’s “checking connection” with the Tablo 2.2.8 and the new Roku app. I tried @TabloTV’s suggestion and loaded the “legacy channel” and every thing works fine for me.

I also have a Roku HD (2500X) with SW V7.0 build 9021 and experience the same problem as @Prowler01 and the others. As mentioned, the buffer loading status displays about 30-40% before throwing the “Checking Connection” error. Here’s some additional info.

  • This problem was occurring when the current channel was in still preview. (Prior Tablo firmwares and Roku OS 6.2)
  • The old channel (now the legacy channel) was able to stream live programming without issue. I have not tried to reinstall the legacy channel yet, but may need to as a [temporary] workaround.
  • My current workaround is to start a recording the “live” program and then switch to watch the in-progress recording.
  • When the legacy channel was still installed, sometimes it would work to start watching the live stream and then switch to the preview channel to watch the live stream there. This method only worked occasionally, but I suspect it may have had the same effect as watching a live recording.
  • I have never gotten a “Checking Connection” error watching recorded content.
  • I tried lowering the recording quality from 1080 / 8M to 720p/5M, but that did not help either.

It’s almost like the live stream is not starting on the Roku soon enough or there is a delay in initializing a new live stream. Rather than wait for the stream to complete sufficient buffering, it’s simply dying.

Hope this info helps and you can find a solution soon. Let me know if there’s anything else I can do to assist with debugging.