Remote viewing only works with freshly rebooted Tablo


#1

Problem:
Remote viewing only works for a few hours at most, and only if the tablo has been freshly rebooted.

Setup:
Tablo connected wirelessly to a TP-Link Archer C9 router. C9 has v1 hardware with latest firmware installed.
Tablo has static IP assigned, and is in the router DMZ. Initially I was only using port forwarding, but decided to put the Tablo in the DMZ as a last resort.

Any suggestions?


#2

What is the make and model of your modem? Is the modem in bridge mode?

Most new modems have a built in router function - bridge mode turns off the router functions on the modem.


#3

I have a Surfboard sb6141 modem, not the rented one comcast provides. Its a basic cable modem, does not have routing or firewall functions. See this link for more details.


#4

Ok makes sense - another way to confirm that is the WAN IP on the TP-Link router should be an External IP. That is an IP that doesn’t start with 192.168.x.xxx


#5

Just checked my router, it does indeed have an external address. 75.67.225.XX.

Anyway, still stumped as to what is going on. If I disconnect my phone from wifi, reboot the phone, then start up the tablo app, it will show “connecting” indefinitely. Then if I restart the tablo, a couple of minutes later the tablo phone app will switch from “connecting” to showing full icons for shows, which I can click on and watch. A few hours later if I launch the app on the phone again it will go back to “connecting”, until I do another tablo reboot.

Any other troubleshooting suggestions?


#6

Weird - have you tried other devices than your phone on a remote WiFi? Not using the LTE/3G connection.


#7

Yes, tried my wife’s phone (iPhone) and her sisters Samsung. Same deal, won’t connect from remote wifi or cellular until I reboot the tablo. My phone is a stock Google Nexus 6p.


#8

@ed_p - Our support gurus are happy to help! Don’t hestitate to drop them a note: https://www.tablotv.com/ask-tablo/


#9

Note dropped, thank you


#10

I have the same problem and have for the year or so I have owned it. Customer support has tinkered with it remotely and hoped the new update would fix it but remote viewing is still unusable/unreliable.


#11

@FarNorth - Eek!

I’ve had this tablo for almost 3 years now. I don’t think Remote viewing has ever been usable. I may install a wireless power plug on the tablo, so I can initiate a reboot remotely. But it just feels like a terrible hack and I risk interrupting any active recordings.

Honestly if folks making cheap wireless plugs, lights and cameras can get remote access working on my home network out of the box without any effort, why can’t tablo?

Also a friend of mine who I recommended Tablo to cannot get it working either. I feel somewhat at fault for recommending the tablo to him. The only difference in his setup is he is running with a Comcast rented combo modem/router.

Anyway, fingers crossed they can fix me. I’m hoping its a known issue by now and they have something in the pipeline to resolve it.


#12

Following up on this one. Tablo support are unable to resolve the issue. In the last correspondence they sent me they are hinting it’s a problem on my end. However they have seen my network setup on a screen share, and everything looks ok to them. And I never ever have any issues with other apps and devices (cameras, lights etc) I control remotely that are on my home network.

I’m at the point where I may buy a new tablo, to see if the problem is indeed something with my old unit. Has anyone else tried this?


#13

If your Tablo works correctly for everything else but remote access, I doubt a new Tablo will make any difference. There isn’t any special hardware that handles remote access (to my knowledge).


#14

Thanks Snowcat for the quick response.

Its either an issue with the tablo, or with my home network, I’d like to isolate both to see which one is the problem. Test cases would be:

  1. My old Tablo on a different network - for example install it at my in laws
  2. New tablo on my network

I’m going to work on #1 first, as it costs nothing. I’ll report back with my findings. If the tablo still doesn’t work with remote connect, I’ll purchase another unit.


#15

Update on this one from Tablo support, after I was able to verify the problem is indeed with the tablo.

"Thanks for testing this out on your end. We’ve sent this information to our development team, and we believe there appears to somewhat of a unique case causing a race condition on the Tablo causing this not to work correctly.

Unfortunately, a new unit would not solve this issue - it’s possible changes in the firmware may be required for this to work as intended. Our development team intends to investigate this ASAP, though we do not currently have an ETA at this time."

I’ll post back here again when they get back to me.


#16

Tablo support fixed this issue yesterday. If you have an older tablo, and have not been able to get tablo connect working, reach out to them and link this thread. Quote from the final email after they fixed my tablo:

After working with our engineers on Friday and today, we believe we have narrowed down the root cause of the problems you’ve been having with Tablo Connect.
Your Tablo appears to have been reporting to our servers with a MAC address error. We have traced this error back to manufacturing, and have since confirmed that it is a unique case - which is why it took us so long to identify.
This was the reason behind your intermittent results with Tablo Connect. We have since updated your Tablo’s MAC address and adjusted the few things that could be affected by this (your subscription, your recordings) to make sure that there is no visible difference on your end - other than Tablo Connect will now working as expected.


#17

Did this really take 8 mths??? Your middle name must be Jobe :grin: Glad they finally got it fixed for you.


#18

I’ve had the problem for YEARS. I only took getting it fixed seriously 8 or so months ago. I think its probably not a common issue, so it hasn’t gotten much love.

But - they got it fixed. So today, I’m happy.