Remote Streaming Quality - setting keeps resetting to 1Mbps


For some reason I keep noticing that the “Remote Streaming Quality” setting keeps resetting to 1Mbps.
No matter how many times I set it to Full Quality, it always ends up going to 1Mbps.

The Tablo is used between a roku (most of the time), ipad/iphone/android tablet/android phone (a few times a week on these), and a Chrome browser (2-3 times per month).

The connection is internal, and this is on a N-wireless (almost never stream on non-wifi – usually with 40Mbps+ even when poor wifi). The Recording Quality is set to HD 720p - Roku/Chromecast.

Could this possibly be a bug?

This setting is set per device and not universal throughout each device used with your tablo. The default setting is 1mbps for each device until it is changed on that particular device.

It comes in handy when you have a phone with a limited data plan and wish to scale down the quality a bit to save data. On the other hand, you may also have a tablet or remote fire tv for example which only uses wifi that you’d like to keep at a higher quality setting.

1 Like

Yes you have to set the Remote Streaming Quality to Full Quality individually on each device. Once set it sticks.

Unless you delete the Tablo app on said device, or delete the Tablo in the Tablo app and re-sync.

You didn’t mention if you were actually using “Tablo Connect” and using these devices remotely - the 1 Mbps setting does not affect local playback at all.

1 Like

@KyleR - I have it set on each device, but I am noticing it resets periodically (and what looks to be randomly). I didn’t think about if the app updates cause the resets (this seems like it should be saved though), but even in the browser (no cookies delete/flushing data) it resets.

I can’t figure out is what’s causing it.

@theuser86 - It’s not sticking permanently it seems. About every few days (4-6) I find it reset.
I am using Tablo Connect (for the phones). That’s very interesting – so on a local wifi (local broadcast) it always uses the full bandwidth? If so – that really solves my problem and I can basically ignore this.

Yes, if you are on your local network, it will always use the full bandwidth.

After reading this thread I’ve been monitoring my Remote Streaming value from the three laptops that I connect with to and sure enough the setting DOES reset itself from time to time.

Last week I made sure all three browsers showed 4Mbps as the value. Today two out of three now show 1Mbps.

Definitely a bug here.


Also see this behavior across all platforms (iOS only one I don’t use)…I think my resets have always been due to a software upgrade of the particular platform - and it seems to default to the 1Mbs setting.

I think that is because the browser software has actually been updated as well…check the HTML version at the bottom of the settings page. I know in my case, the reset is associated with updates, including the browser.

@ventz There was a similar issue related to this one ages ago on the original Android app. Make sure you’re using this one on your Android tablet, just incase. The original app has since been discontinued.

@TabloSupport - just checked, I am on the version you linked. I’ve been keeping an eye on this, as other said, all of the clients updated at one point or another. It looks like the settings are just not persisting. Once “Auto” is released, it would be great to default on that :smile:

I don’t use the Mbps settings, but the ‘Fully Quality’ does stick. I have only had to change it after updates to the apps.

Ok, so opened web “app” today (Chrome) after I saw the email about the firmware (2.2.2 update). The web app had to sync down the shows, and that made me wonder if it reset. Checked in the settings, and sure enough – it was reset back to 1Mbps.

If I read this thread properly that setting seems to be on a per device basis. I think I may have an issue with this.

Let’s assume I have an 8Mbps upload speed on my internet connection, then I would set the Remote Streaming to 4Mbps so that my pipe does not get saturated if someone remote was streaming TV.

I would NOT want anyone, say my son for example, to change that setting on his device to allow the full stream through as that would fill my 8Mbps pipe with a single use.

I think this should be revisited and a Global max stream setting should be in place.

1 Like

@luker, per device still makes the most sense. My cellphone can be at 500k or 750k on cellular data, and 1 or 2 Mbps on wi-fi. If I bring a laptop somewhere, 4 Mbps is feasible. A tablet can be in between.

It seems much easier to have it per device rather than having to adjust it every time if using multiple devices. And if you don’t want your son to use full quality, then just tell him. :wink:

Fair enough, but there needs to be a Global Maximum and the constant resets in the browser need to be looked at.

Maybe a password to change it or WHEN login gets done have an administrator level allowed to change everything and upgrade and a user level for children.
Can you tell I used to be a programmer?

Hey folks,

Thanks for all the details - and for the great feedback. We’re revisiting some testing on this now to see if we can reproduce. Worth noting: did any (or all) of you see this behaviour on the most recent firmware release; 2.2.2?

Still waiting for the firmware update to come :slight_smile:

Just rebooted today and I got prompted for an update (didn’t before - which is kind of weird).

Anyway, it seems like the setting did NOT change in the clients after the firmware update.
I’ll keep an eye on this over the next few weeks and report back.

1 Like

How are you liking the firmware update? Its perfect, though of course we still have the “to do” list with still more changes. Let the developers have a week (or month) break before starting back to making the Tablo even more awesome.