Remote Connection Setup With Linksys WRT Router

#1

Recently purchased Tablo Dual Lite and could not get my Linksys router port forwarding the remote connection. I worked on it for about a week and finally came across some information and the solution to fix it. The main problem was the web gui for my router is very poor and apparently does not display all the capability of the router. In the port forward settings there is no option to map to internal port, it only allows entry of the external port range. The router can be programmed to map the internal ports to work with Tablo and also I fixed another device I was having issues with, so it was a win-win. This is probably a guide for medium knowledgable techies, not for beginners…

Special thanks to [Andriy_] on the Linksys forum, I took his information and made a guide:

This process is easiest if you login to router and make the two rules in the web interface, then do a simple edit, make note of the Tablo IP, change the ip below to yours. After adding the rules, exit the web interface.

using Putty (free download on internet)
ssh to the router using router ip address

login using ‘root’ as user
router admin password as password

add the 2 rules to /etc/config/firewall:

cd /etc/config

vi firewall (this opens the file in editor, editor is little bit cryptic)

add or modify the two rules, using arrow keys on keyboard and the insert key:

config redirect
option proto ‘tcp’
option enabled ‘1’
option target ‘DNAT’
option src ‘wan’
option dest ‘lan’
option name ‘Tablo1’
option dest_ip ‘192.168.1.128’ (change this to your tablo ip)
option dest_port ‘8887’
option src_dport ‘21757’ (change this to the port shown in remote connect panel)

config redirect
option proto ‘tcp’
option enabled ‘1’
option target ‘DNAT’
option src ‘wan’
option dest ‘lan’
option name ‘Tablo2’
option dest_ip ‘192.168.1.128’ (change this to your tablo ip)
option dest_port ‘80’
option src_dport ‘21756’ (change this to the port shown in remote connect panel)

then save and exit using these commands
:w
:q

then login in the web interface, restart router, or add another dummy port forward and save to force update then delete the dummy rule.

1 Like
#2

What router? WRT is just the beginning of the model number, for example WRT54G or WRT1200

#3

Mine is Linksys WRT 32X. But this would probably work on many other Linksys routers.