Registration Error, Unabe to add "Tablo"

Got everything setup and working on Roku.

Side Note: (Love it but Please make Roku app nicer, it is pretty basic)

Now for my real issue. When I open the iOS app on a iPad 2 running iOS 8.1 it finds my Tablo but when I hit connect all I get is:

Registration Error, Unabe to add "Tablo"

I am using the latest iOS App and my setup is the 4 Tuner Tablo and I am using the 2TB HDD in the link on the FAQ.

Any other setup info needed?

@roraniel What do you see in the top right corner of the ‘Connect to Tablo’ screen? Is it a refresh or an Edit button?

If it’s edit - tap it and select ‘Delete Tablo’ then you’ll be able to re-add it. If it’s a refresh - try this too. Do you get the same error?

Delete the iPad app, turn off and on the iPad and then re-install the app.

I’ll try that tonight. Thanks.


If @theuser86’s suggestions don’t help, just try a regular reboot of the Tablo: press and quickly release the blue reset button on the back right of the box. It will boot up in ~1 minute.

P.S Lots of love coming to Roku soon, stay tuned :slight_smile:

No iOS App love with either of these suggestions.

Any further advise on this issue? Still cant connect on iPad 2 iOS 8.1

It is a refresh button. All can do is hit the refresh button but no option to delete Tablo. Sane error after hitting refresh multiple times.

@roraniel Look to the top left of the screen. Do you have a ‘back’ arrow there? If you do, follow it. It will display Tablo’s already on the network that you’ve connected to.

If not, try the Tablo web app through (mobile) Chrome - just to see if you can at least get sync’d.

No Back Arrow. I did get synced in Safari.

I think this weekend I will try restoring the iPad and see if starting from scratch helps.

I restored my iPad this weekend and got the Tablo app to connect to my Tablo however, it keeps loosing the connection and I have to re-boot the iPad to get it to connect again.

@roraniel What model of the iPad are you using? We’ve never heard of physically having to reboot the iPad (especially more than once) just to connected. Is there any chance the iPad itself has some issues?

It is a iPad 2. I guess there could be something wrong with the iPad but this is the only app giving me an issue. It is not essential to get this working as I use the web app to configure Tablo and I don’t really plan on using the iPad to watch Tablo content. I travel a lot and find watching movie files on my phablet more entertaining and more convenient than hauling around a tablet in addition to my laptop. I just whip out my Note 4 on the plane, sit back, and enjoy.

I just installed this app on the iPad to check my new toy the Tablo!!

I’m having this exact same issue. Did you get it resolved. Also…any chance that when you siad “iPad 2” — you meant iPad AIR 2? I have two of these – neither can connect.


Do you have a computer with a Chrome browser you can use to set up the Tablo? Or is your Tablo already configured and working on other devices?

@iHuman Which ‘part’ of the issue are you seeing? Will it never connect, or does the iPad just return ‘No Tablo’s found’? Is the setup on Wi-Fi or Ethernet? Feel free to send me the details directly.

@iHuman No I just gave up as I never really intended to use the iPad for Tablo anyway.

I even went as far as doing a factory restore on the iPad and installing nothing but the Tablo App and still no joy so I just restored my iPad from a backup and like I said, gave up.

I use an iPad 2 (not air), but I left it at iOS7. No problems after tapping the reset button briefly, then once Tablo’s wifi shows in the wifi list and I join, go back to the Tablo App and select my wifi network. It might take a few tries to get the Tablo wifi to show up before it stops blinking. After that the app does a sync. I don’t believe the iPad 2 works well with iOS8.

I have this same issue with the iPad Pro 12in.