Recording failed because no hard drive was connected

I’ve had two instances lately where the Tablo device wasn’t responding.  Pull the power and it comes back up with failed recordings and the error "Recording failed because no hard drive was connected."

Is this a sign that my hard drive may be having issues?  Any built-in diagnostics or SMART error reports that I should be looking for in the UI?  If I do need to swap drives, is there any way to transfer files from the old drive to the new drive?

Note that this is with the 2.1.20 firmware, I didn’t get the beta firmware pushed because the device has been locked up for the last day or so.

What kind of hard drive is it? Was it one in the Tested Drives list?

My Elements drive needed a firmware update to work properly (and it wasn’t easy to find). Submit a ticket to support.  They can look at your configuration and logs and make recommendations.

@pnear I can take a look to see how frequently this is happening - feel free to send me a note. We’ll see what’s going on.

It’s a Segate Backup Plus 1TB, on the good list and has been working for several months up to now.

Will submit a support ticket to see if we can get any details from the logs.

Followup for anyone who gets to this thread through a search with the same error.  Support has suggested that I try a different USB3 cable, as they’ve had reports of poor-fitting connectors with the cable that ships with some of the newer model Seagate drives.  Logs showed frequent disconnects of the hard drive, which they’ve seen before and tested by replacing the cable.

I happen to have another USB cable (also Seagate, but gets less use) which I’ll try out for a bit to see if that makes a difference.  New USB3 cable is on the way from amazon as well.

Does anyone have a fix for this issue? I recently purchased a Tablo. So far it has been a nightmare. We finally were able to be a part of the new 2.2.5 beta, because we were not having any success with recording.

So, yesterday we set a bunch of manual recordings, and they all appeared to be successful - great, problem solved. But no, a scheduled recording that was set last night showed up in the “failed” list this morning - Recording failed because no hard drive was connected.

Why would this happen when obviously the hard drive was connected just a few hours prior? The equipment is all in a cabinet - out of sight - it does not get moved, bumped, etc.

Any help is appreciated.

@iwan2noy - Although a hard drive might be physically connected, some drives can become ‘software’ disconnected from the Tablo. In that case, the Tablo would not be able to ‘see’ that the drive was connected.

Some drives do have particular problems with this type of disconnect which is why we provide recommendations on hard drives here:

What type of drive are you using?

WD Elements 2TB Portable External Hard Drive

That is a recommended drive, and it should not have happened. I had this same issue, and I downloaded the flash utility from Western Digital. Even though it said my firmware was up to date, I flashed it any way, and my issues stopped, it has stayed connected since.

That’s bad news. That’s the drive I just bought to fix my ‘software’ disconnected hard drive. :frowning: