Port forwarding trouble xfinity Arris tg1682g

I just bought a Tablo Quad an am trying to connect remotely. the port forwarding options on my router only give the options for start and end port, not private port/public port. What numbers to I use?

Thanks in advance for your help.

Share a screenshot of the port forwarding settings. If the link below is correct, the router function on the ISP modem / router combo doesn’t allow port translation. That is you cannot forward external port 20394 to internal port 80. Almost all new routers let you do port forwarding translation. This is a limitation of the modem you have.

Change the Tablo settings to forward Public Port 80 to Private Port 80. This is direct port 80 to port 80, might work.

https://portforward.com/arris/tg1682g/

Another helpful link.

Will try forwarding port 80, thanks

Should I consider Comcast business internet which allows static ip?

No you don’t need a static IP. The Tablo can handle IP changes.

Try this - turn on UPnP, toggle the Remote Access off and back on. UPnP should get you connected. But then for security reasons, go ahead and turn UPnP back off. It worked for me, and I am also on xfi with a TG1682.

I’ve received advice related to DMZ, DHCP and port forwarding. Should I delete/disable all that before trying your method?

That did the trick, thanks for your help

Interesting - show us what the port forwarding settings screen shows now that it is auto-configured by UPnP.