Port Forwarding - Driving me Crazy!

I’ve spent many many hours trying to get this to work without success. Any help would be appreciated.

Problem: Cannot get Tablo Remote Access to work

Equipment : Windows 10, Tablo TDNS2B-02-CN, Netgear Nighthawk X6 Model R8000 Router, Motorola MB7620 Modem

Things I have tried

Turned on router UPnP. At first the router recognized the Tablo port numbers, but had the wrong IP address. On recommendation of the Tablo site, I updated the router firmware. Now UPnP does not recognize the Tablo at all. Tried rebooting, no success.

Set up port forwarding in in the router settings, (Screen Shots Below) using the numbers on the Tablo setup page. No luck, sill showing Your router requires manual configuration. I also noticed if I uncheck the “Remote Access” in Tablo, and then recheck it. The port numbers in Tablo will have changed. Often the Tablo IP address changes also.

Contacted Motorola: Confirmed that this is a simple passthrough modem that cannot create a double NAT situation.

Below are my Tablo and Netgear setup screens

I recently set up Port Forwarding; below is what worked for me.
31881 —> 8887 (TCP)
31882 —> 80 (TCP)

Thanks for your help. I just tried your settings. Still no luck.

I suggest you disable UPnP.
Why is the Service Type in the router FTP and not TCP/UDP?
Lastly, make sure the ports are open

I’ve disabled UPnP. I don’t know why it shows the FTP. From what I’ve read that space is meaningless. TCP or UDP are not even available in the dropdown. When you go into Add Customer Service or Edit Customer Service, that is where you select TCP Protocol. (See Screen Shots) I had to edit again because after turning off UPnP and going back to Tablo setup the IP address hand changed once again. I don’t know how to check if the ports are open. Any help would be appreciated.

First assign a permanent IP address to your Tablo. That is probably part of your problem. Then try the suggested port mappings and see what happens.

My settings appear to be automatic. However, I remember years ago in 2015 or 2016 when I first set up Tablo Connect that I had to do the port forwarding. Don’t know why I don’t have to do it now. I simply check the button and it works. I’m using an Netgear Orbi 3-unit wireless mesh.

UPDATE: I just read the article on Port Forwarding and UPnP allows automatic setup, if supported by your router. I have UPnP turned on so I didn’t have to do the port forwarding.

Tablo_Connect

I went into the router Advanced Settings : Setup, and entered the settings below. Still no luck. Let me know if I did this correctly.

Yes I’ve tried UPnP and still got the same message. Your router requires manual configuration.

That is correct. Now why you can’t get port forwarding to work is another thing. Once I assigned an IP address to my Tablo, the port forwarding seemed to just work.
Sorry I can’t help further. Past my pay grade. :anguished:

With UPnP turned on in your router you have to let Tablo automatically setup your port forwards. If you try manually setting up the ports with UPnP turned on, you will continue to have problems.

I have remote access working on mine, but it was a little temperamental for me to get working. As I’ve scanned the thread, at a high level to me it looks like you are configuring the port forwards correctly on your netgear router. As you noticed though, if you uncheck and re-check the remote access, the ports will change. When that happens, you will need to update your port forwarding rules according (so use the ports that your Tablo is showing you).

Even though this shouldn’t matter, but are you using a wired connection or wireless to your tablo? Can you go into the settings and confirm the IP address it has along with the MAC address? I attached a screenshot from mine to show that info. I just wanted to rule out a “fat-finger” for the DHCP reservation you setup, as I’ve had that happen to me before. Also as strange as this sounds, I had a couple random glitches where the IP address on my tablo changed even though I have a DHCP reservation setup for it. If you notice that (IP address not matching your reservation), best thing that worked for me was to reboot the Tablo by pressing the blue button (do NOT hold it in! - just press and release).

Once you’ve confirmed the port forwarding on the router along with the IP address on the Tablo, can you press the “re-test port mapping button”? It’s been awhile but I seem to recall I had to do that once I had my gear properly configured before it started working.

I also had another idea, but it’s a real long-shot. If everything is setup properly but not working, you might want to check with your ISP just to confirm the ports aren’t being blocked by them. I’ve heard to various ISPs blocking some traffic, but that seemed to happen more in the past that it does today. As crazy as this sounds, but you don’t have any other devices between the netgear router and your tablo right?

Is your modem in bridge mode? Have you checked for a double NAT?

https://kb.netgear.com/30186/What-is-Double-NAT

https://support.google.com/wifi/answer/6277579

http://www.practicallynetworked.com/networking/fixing_double_nat.htm

You probably want to re-post that screen shot and obscure the MAC address of your Tablo.

Good point, thanks!

Tiberious, I double checked my port forwarding rules to make sure they are correct. I am using a wired connection to my Tablo. I also double checked the MAC address and IP address to make sure they matched. I have noticed that since I set up the static IP that the IP remains the same even when I check or uncheck UPnP, which I suppose makes sense. There are no devices between my Netgear router and the Tablo. Next I’ll be contacting my ISP provider. It’s a small company and customer service is hit and miss.

Yes I have checked for a double NAT. My modem is only a modem and not a router. I’ve contacted Motorola who confirmed that I have a simple pass-through modem that would not create a double NAT.

From what I understand, if you are defining the port forwards, keep the UPnP off. It’s good that the IP address of the tablo isn’t changing. I keep thinking I am overlooking something but not sure what else to look at.

Based on your previous posts, would this still be your current ports for forwarding?:
External → Internal
31882 → 80
31881 → 8887
Well, I saw that in your router screenshot and hopefully those are the ports being reported by your Tablo (originally they were 21957 and 21958 in your first post). Just please be sure you are starting with the ports being reported by your Tablo and then setup the port forwarding in your router accordingly. Oh, and don’t do what I did my first time which was to get the ports reversed (so I was using the right external port numbers for forwarding them to the wrong ones on the tablo).

I saw you previously asked how to tell if the ports were open and I know a couple little tests but I don’t want to lead you astray too far (this can be quite the rabbit hole). BUT if you’re interested, here’s what I use however I am sure there are other ways to do this.

One option is to use telnet to try to connect to a port. There’s a great example on how to do that here: Using telnet to Test Open Ports | Knowledge Base
Now I only used this to test the INTERNAL ports to see if they are open/working on my tablo. So for an example, I would use the command telnet 192.168.10.141 80 and telnet 192.168.10.141 8887. Per that article, if you see a blank screen, you got a successful connection so don’t let that throw you off. Also keep in mind I am running those commands from a laptop that is connected to the same network as my Tablo. In short, I am running this INSIDE my network. At best, this will show that the tablo is working but does NOT test your external connection/port forwards. I have never tried to run this from outside my network so I don’t know what to expect if you do that.

I like to use a program called nmap (www.nmap.org) to check external/internet connected hosts. This is a pretty useful utility but may not be too easy to use. Below is a screenshot from a test I ran from a laptop on my network. I have blocked out my IP address for security reasons.

What I have in my screenshot above is running nmap to scan specific ports using my PUBLIC (external) IP address. Now that would be the IP address assigned to the WAN/internet port of your router. Let’s just say that address is 1.2.3.4 for an example. In my case, my tablo is using ports 21400 and 21401 for the port forwarding. The command string to use (so the “command box”) would be nmap -p 21400,21401 1.2.3.4. In your case, you would need to change the two ports to be checked along with the external IP address. In my screenshot, we can see that the ports are open. ONE VERY IMPORTANT POINT! - if something isn’t configured right, you will most likely see the results as the ports being closed, which would look like this:
image

As silly as this sounds, have you rebooted your router after you configured the port forwards? I looked up that router and I see it has options for TCP, UDP, or TCP/UDP for the port forward rules. As crazy as this sounds, maybe configure the port forward rules for “TCP/UCP” instead of just plan “TCP” (which in all honesty is what it should be). Anyhow, sorry for the long post. Hopefully it doesn’t lead you astray. Good luck!