Port Forwarding And TP-Link

I have a Mediacom Modem. Previously had a Google Router. Had port forwarding set up for Tablo. In the Router had the 2 forwards, then in the modem had the forwards set up to the router. Everything worked just fine, I had remote access to my Tablo.

Replaced router with TP-Link unit. Set up port forwarding there identical to old router. Would not work, I had no remote access. Turned off connect in Tablo. Hit manual setup. Got new port numbers. Deleted everything in my modem and router and re-configured with new port numbers. Hit test button, didn’t work. Redid this several times, rebooted, etc. Still won’t work.

Any ideas what could be different in new router that I need to change or fix?

If you have port forwarding in the modem, then it’s not just a modem, it’s a combo unit. It needs to be in bridge mode.

It is a combo unit, but I don’t use the router portion. I use it just as a modem. There is no option for bridge mode. Apparently Mediacom doesn’t allow that.

In any event, it worked fine until I changed routers. So the problem doesn’t appear to be in the modem it is in the new router.

If you can’t do bridge mode, then it IS a router, and you shouldn’t be using a second router. Why do you have the second one?

1 Like

Yes it is a combination modem/router. But I don’t use the router portion, except for the one connection to my router. I use a separate router for greater functionality. I get better WIFI coverage with a different router. My separate router has built in VPN server. It has ability for a USB drive. ETC. Pretty common to do things that way and I have done it for years with several different systems.

So the setup is fine. Just doesn’t explain why one router worked and the other one doesn’t.

What do you mean “I don’t use the router portion”? Do you have it disabled somehow? By default, a unit like that would be in router mode, which means the Wifi will be on a private network separate from the uplink network. If the uplink is already a private network, then you’re in double-NAT land and everything breaks.

Look at the WAN and LAN IP addresses for both routers. If the LAN address of the second router is in a different subnet than the LAN address of the first router, you have a problem.

What you want to do is put the second router in “access point mode”, if it has such a thing. Or just get a real Wifi access point and not use a router as an access point.

Here is how it is done. Been doing it for years, and so have others.

The modem/router is connected to my ISP which gets a public IP. This unit then NAT it to its router portion. The WIFI on that unit is turned off. The LAN portion on that unit is set for 192.168.0.. Then an ethernet cable is run from one of the LAN ports to the WAN port on my other router. That WAN port then has an address of 192.168.0.. (in reality it is a fixed address so I always know what it is). Then the LAN on the main router is 192.168.1.*. It then connects to all my WIFI and hard wired devices.

This method is widely used not just by me. It works great, nothing breaks, or at least it didn’t till I changed routers. And then only the port forwarding for the Tablo broke. Everything else works just fine. My DDNS works, my VPN works, etc.

There are a lot of IT people that recommend using a separate router from the modem and that is exactly what I am doing. If you have never done it then don’t say it won’t work or there will be problems. Just not so.

In any event, I don’t wish to discuss it further. If anyone has any info on the TP-Link that might help that is all I’m asking. Otherwise Goodbye.

When the Tablo doesn’t configure and gives you new port numbers have you tried changing the port numbers on the Tablo to what you have set up in the router? That is the way I’ve had to do it.

In case you are using the Apple TV app the new port numbers don’t stick when using it and I had to use the Web app to set them.

It was the Apple app. I used the Web app and it worked. Been so long since I had did it last I think I forgot about that. Thanks.

Clarification, how do you view this and “not a router”. It’s “controlling” internet access and primiary DHCP and secondary router, is just routing traffic to the primary router which in turns connects it to the outside.

From the modem to your router. Many have just a “cable modem” with establishes network connectivity from the cable, which in turn your personal router gets the WAN IP.
They don’t warn of double NAT?

It’s the ports on the primary router is what would receive the request from the internet. Your personal router never sees this and is essentially it’s own isolated network.

We can argue semantics all day, but it doesn’t make any difference. It works, has always worked and has worked fine for years. DDNS works fine. Remote access to my network via the VPN server in my router works. My port forwarding now works fine once I configured the Tablo from the web app instead of the Apple app. So everything works just like it should. If you think my method is different that yours so be it. Makes no difference since the end result is the same.

Out of curiosity, are you running the latest Tablo firmware (2.2.42)?

Yes.

Viewed as semantics… a search for double NAT doesn’t show one result with - it’s ok since everyone does it.

Many articles why not and potential problems associated with this set up.