Poor picture quality on interlaced (1080i) channels

Just got my Tablo 4-tuner a few days ago and so far I (mostly) love it. But one thing that is bothering me and I haven’t seen anyone else mention is that the picture quality is quite poor on 1080i channels when there is motion. I believe what I am seeing is interlacing artifacts or “combing” as a result of poor conversion from 1080i to 1080p. I have my Tablo set to record in 1080, my roku is set to 1080, and my TV is showing it is taking a 1080p signal from the Roku.


The artifacts are really, really evident any time there is horizontal motion, like when a ticker is at the bottom of the screen, or just a left-right panning shot in a TV show.

Is this a known issue, and is there any way to fix it? Not sure if setting Tablo to record at 720p would make this problem any better, but I haven’t tried it yet.

This.  It’s actually one of the first things I noticed about the picture quality.


@Auream is this what you saw?  https://www.dropbox.com/s/rifreyiluxylaoo/2014-06-20%2020.27.48.jpg

Same thing here.  I got mine set up over the weekend, and actually watched some NASCAR (Gasp!) to see how it handled motion.  I was a bit disappointed.  It got me thinking about running some coax straight to the tv for watching similar events.

(No offense to NASCAR fans.  I really did like that road course.)

@Pundit @theKman

Interesting... I have not noticed any issues at all with picture quality even on livetv.

a few questions:

1) in the tablo app on webui or tablet - if you go to settings do you have your recordings quality set at 720p or 1080i ?

2)  is your tablo wired to the network (whats your network speed?)

3) is the device in the above pic wired or wireless?  (again whats the speed)

Reason I ask is it could be a case of the quality suffering due to lack of bandwidth.  Also - what happens if you pause live tv for like 5 seconds and then let it resume? does the quality issue go away?

@PiX64


1) Currently I have it set to 1080i.  Truth be told, when I took this pic I’m not sure what it was set at 
:slight_smile: First thing I did was set it at 1080im but that was via the Android app, which doesn’t appear to have a Save button on the settings screen.  So I’m not 100% what it was set at.

2) Tablo is wired into a gigabit switch.

3) The above pic is from a wired Roku 2 XS on the same switch as the Tablo.  The TeeVee is an oldish Vizio which maxes out at 720p.

I haven’t tried the pausing thing yet, will look at it later.

So far I’m reasonably impressed by the Tablo.  The Android app is pretty buggy still (e.g. when I view Live TV it always goes back to the start of the buffer, not the current live position), but the web app is solid, as is Roku.  My biggest issue is signal strength, but I’m mindful to pay $200 for a pro install of my HD antenna into the attic

I had a busy weekend so didn’t get to tinker with it much (plus the soccer is on WatchESPN), but I did instruct the wife to watch her morning programs through the upstairs Roku.  I still need to plumb in the downstairs Roku to run in parallel with the TiVo, but I’m short an Ethernet connection.  First world problems.


Interesting… i wonder if it has anything to do with that Rokku 2XS.


Primary watching in my household is done via Roku 3s, tablets, and browsers.  I have a few roku 2 xs(s) but they are not used all that often.  Ill try a wired roku 2 xs later and see if i notice a resolution/stutter issue.  You can see the quality in some of the videos i shot.  It does work and looks GREAT  :-)  hopefully we can get you to the same point.  again by we i mean mainly @TabloSupport  :-)  ill help as much as i can though.  just @ mention me in posts.

@PiX64 the downstairs Roku is a 3, so I need to get it connected and have a look.


I also noticed the combing while viewing live TV via Chromecaset.

@PiX64

1.  720p

2.  Tablo is connected to a gigabit router via ethernet, and to two Roku 3 devices via wifi at 5ghz.  The router is about 20 feet from the primary Roku.

Most video looks very good through the Tablo, just not fast motion, especially horizontally, and especially light/white colors.  For me, this is kind of a “streaking” in the image, I think it’s the same thing in @Pundit’s pic, but it’s hard to tell without motion.  I also experienced some “stuttering” in the video feed.  It was very minor, I would say it jumped ahead a fraction of a second, but did so regularly.

On another note, just today I found that my guide data was missing for all but two local channels.  I re-scanned for channels, but that had no effect on the guide.  Is there a way to force a reset/update of guide data? 


@Pundit

Ah, “combing”, I was not familiar with that term.  I just looked up some examples online, and I’m pretty sure that’s what I was experiencing.  I need to get some viewing in today to see if it’s still happening though.

I noticed this issue as well…but only when I set the tablo to 1080p recording. I toyed with 1080p the first night I had it, and had it record a show. It was a 1080i channel, and it indeed looked pretty poor with some pretty bad combing and what appeared to be some dropped frames. I had already changed the Tablo to 720p before I noticed this (due to bandwidth issues to one of my Rokus), and haven’t noticed any combing since then. Perhaps the deinterlacing needs a fix.

@theKman @PiX64


Here’s an example video that shows combing - this is exactly what I’ve been seeing

https://www.youtube.com/watch?v=ltDjvCxFTco

Any chance you can try that same test with the roku 3 wired?  Id bet the choppy and blocking goes away.

This effect is DEFINITELY due to poor/nonexistent deinterlacing of 1080i signals. If you do a google search for “combing artifacts” you’ll come up with tons of examples that look just like what I see. I have a Roku 3, so this has nothing to do with the version of Roku. If going to 720p solves this problem, I’d just assume do that, but its unfortunate that we can’t get the best quality possible.


This is also definitely not anything to do with network speed since both my roku and Tablo are on different ports of the same gigabit switch.

Question for one of Tablo’s tech guys: is the problem that the Roku or other playback device is not doing deinterlacing when fed a 1080i60 signal? Or is it the Tablo’s fault in that its taking a 1080i60 signal, and combining the fields into a 1080p30 video file, in which case there’s no way that the next step in the chain (Roku, tablet, PC) could possibly remove the artifacts because the interlaced video has already been (poorly) converted to progressive?

I have the same thing. I will need to check the upstairs tv, but I was recording 1080, ran wireless to Roku 3 (forgot it has 1080 or 720 so not sure its setting). Tablo is ethernet to my network…


I changed the recording to 720 and will see if there is a difference.

I too didn’t know the name of what was happening.

LOVE THE TABLO though!

@napercort can you try the same thing?  connect roku 3 to network via wire and see if the issue still exists?

@Auream - google searching will also reveal that just because 1080i is a higher number and pixel depth doesn’t mean necessarily that its a BETTER quality than 720P.  you also have to factor in the progressive scanning technology vs interlacing…  only reason i bring that up is that one could argue 720P IS a better pic quality than 1080i…

@PiX64 Sorry, The one isn’t via wire while the second is. 


Would a Powerline Network Adapter work? It is my understanding that that makes for ethernet type connection away from the actual Internet source…is that correct?

@PiX64, that is not correct in this context. If the original signal is 1080i, then you will preserve better quality by leaving the recording at 1080i than if you downsample to 720. Anything that says otherwise is referring to the original signal being either 1080i or 720p, in which case there are arguments for each. But once you already have one type of signal or the other, you’re better off quality-wise leaving it in the original resolution.

Also this has nothing to do with wired vs wireless. Its impossible for the signal being wireless to cause this issue.

For what it’s worth, the TV set post-processing can come into play as well. Don’t overlook these settings when troubleshooting. 


I have a TV that by default upscales the refresh rate from 60hz to 120hz. This is ok for OTA sources but once I record the same OTA sources to a Tablo and play them back through a Chromecast device, the 120hz TV upscale processing is just awful! Leading to jittery playback during any pans and zooms.

So I turn off all my TVs post processing junk, record in 720p on my Tablo, and find I am satisfied.