Plex unable to play certain episodes and certain shows?

Something has happened to my plex running on Mac OS in the last three weeks. There are handful of episodes I am unable to watch, even some episodes that we’ve watched already will not play. But it seems stuff older than three weeks plays just fine. I have been using Plex since @Davidvr made the Tablo Plex channel. I just updated Plex to the latest version and it did not help. Anyone have any ideas?

That is a third party development project. You may want to post your issue here: 

Which version of the Tablo plugin are you using?

Can you play the videos on your computer where the Plex Media Server is?

I don’t know how to tell which tablo plug-in I have. when I click update channels it says they’re all up to date.

I have the same problem when I play it on the computer or the Apple TV.

The same episodes play fine on the iPad using the tablo app

You still haven’t told me if the episodes play fine on the computer through the Plex Media Server.

In PMS you can go to Channels and find the Tablo plugin and try playing it through there. Do not use another computer that is running Plex Home Theatre. If it works through PMS then it is an issue with how the Plex server is delivering the video to your front end say the Plex channel on the Roku.

The episodes in question do not play on the computer via Plex media server

If they don’t play on the computer then it’s something wrong with the Plex plugin.

Can you try the beta?

I’ve tried a few things I’m not sure what’s going on. On a sidenote I just upgraded to a 4K TV and a 4K Blu-ray player. I figured I would take that opportunity to restart everything while I was removing some extra unnecessary wiring from my media room. Started everything back up no luck, uninstalled tablo channel and reinstalled, no luck. Everything that won’t play is also missing the artwork. Artwork and play function is fine on the tablo iPad app. Everything that recorded last night plays fine and has the artwork. The only other thing I’ve done in the last week is, I deleted a bunch old episodes and unscheduled some recordings. I’m not sure if that had anything to do with it.

Figured out how to delete tablo cache in the Plex folder, still have episodes that won’t play.


Did you ever get this fixed? This just started for me a couple days ago. It isn’t all recordings, just some. The ones that won’t play are missing artwork.

I can play them from so the recordings are still there.

The one thing I haven’t tried is playing it from Plex using a different machine.

Update on this from my side.

I talked my wife through a few troubleshooting things. She received the same error when playing from her MacBook through Plex. “Cannot load M3U8: crossdomain access denied”

However, it eventually played after a minute or two (I have no idea how she could wait that long). Using Plex Home Theater, the error was the same, but it wouldn’t play.

I never did get it fixed or the episodes to play but it only happened over that 3 or 4 day period and hasn’t happened since.

This morning I spent a bit of time trying to figure this out - and I’m not working/typing from my phone so I can give a bit more information. I had two different errors.

  1. If I was using Plex Home Theater, the error indicated the file couldn’t be found. This made me initially think it was a Tablo issue. But, I was able to play the same recording using the Tablo web app so…it’s not Tablo.

  2. If I was using the Plex web app - it gave this error. Cannot load M3U8: crossdomain access denied WTH. This made me start thinking it was a permissions issue or maybe something with encoding.

I tried uninstalling the Tablo channel, renaming files, etc. I figured I’d try to fix the PHT issue first, even though the two were probably related. “File not found” seems a heck of a lot easier to fix than crossdomain scripting problems :wink:

When using the web app, if you go into the recording info it doesn’t tell you where it expects to find the file. However, if you click View XML it does. I saw IP references to, I check the current IP address of Tablo…it isn’t

So now I had to figure out where it was getting the reference to the old IP address information. I’m on a Mac, so how you get this info will vary.

Within Terminal use: mdfind “”

It quickly located the file
/Users/Dave/Library/Application Support/Plex Media Server/Plug-in Support/Data/com.plexapp.system/Dict

Open up the file with the text editor of your choice, find the old IP address, replace with the current IP address. I restarted Plex - I don’t know if it was necessary or not. Open up PHT, my thumbnails all appeared correctly and I was able to watch videos that weren’t working previously.

To avoid this in the future, I put in a DHCP reservation for Tablo on my router. :blush:

Hopefully this helps someone else out.