Playback problems since updating firmware and Roku channel

I’ve been experiencing intermittent problems with playback since the 2.1.12 firmware update yesterday, and the Roku app update to v1.1, build 8.

While playing some shows on the Roku stick, it will frequently pause for several seconds and display “Loading, please wait” (or something similar) with a progress bar.  Before showing the message, the video gets choppy and slows down.  This happens so often on some recordings that they are unwatchable.

On the web interface, the same shows play fine, so I think the problem is on the Roku.

My hardware:

Tablo 2 tuner version with updated firmware
Roku 3500R Streaming Stick (2014)
WD Elements 1TB drive

My recording quality is set to 1080p, and I’m using wireless on the Tablo.  The Tablo is very close to the Roku stick.

For the web interface I’m running Windows 8 Pro with the latest version of Chrome.

Overall, I’m loving the Tablo so far.  We just lost our Aereo service and this is a great alternative to cable.  Hopefully these playback issues are just a temporary nuisance.

I actually experienced a fair amount of buffering very similar to what you experienced this morning on my wired Roku 2XD.  The buffering breaks were a second or 2 at the most, but they happened fairly frequently.  

Hi Andy - We’ve seen a few issues with streaming quality with the Roku stick. Its WiFi antenna can be a bit dodgy. 


The team @TabloSupport will be able to help you troubleshoot further.
1 Like

Thanks.  How do I contact TabloSupport?

My main concern is that everything worked great for a week (when I got my Tablo) and then this started happening immediately after the updates.

I doubt that it’s an antenna issue since it worked previously and all of the other Roku channels work perfectly well.

1 Like

Never mind.  I figured out how to submit a request.  Thanks again.

@AndyW I had the same thing after the update before this one…then all of a sudden it stopped. We (support and i) didn’t really do anything. 


Suggestion would be the wireless tablo. About the only thing I did (and not sure when I did) is connect my Tablo to Ethernet. The location of my Tablo is away from my router, so I bought a power ethernet and while the connection is not the greatest, I don’t have the loading please wait notice any more.

Knock on wood!

1 Like

Add me to the list, am experiencing the same buffering problem after the update.  Using a 2-tuner Tablo, Roku2XS, wired.  Never had any issues like this until after the update.  Buffering problem on a program recorded last night, and one recorded a month ago.  Last night after the update I successfully (no buffering) watched a 480 4:3 movie, today the higher source resolution (720, 1080) content is not playing correctly (I was thinking bandwidth issue, but web app works fine - Roku bug?).  My Tablo is set to record at 1080.

The buffering problem does NOT happen when watching via the web app (Chrome).

Also buffers Live TV.

I changed my resolution to 720 and am still get some buffering (not as much, but still there).  When rewinding or forwarding there is definitely a longer lag before the picture returns.

One observation, when the program started buffering I hit rewind to play the same segment again, and each time the buffering occurred at the same place.  So it doesn’t appear to be an actual bandwidth problem, but more of an issue with the Roku processing that section of the recording.  I noticed this on a fresh recording (after the last firmware/Roku update), and on a program recorded more than a month ago.

1 Like

I’m still getting this if I watch recordings or live TV at 1080p, but I turned the resolution down to 720 and it’s working ok for now.  It’s unfortunate that I have to record at a lower quality, but at least it works.

@mbellaire i have had the same loading please wait since i got tablo and have tried all kinds of things to fix it.  it did work for 1 day after suggestions from fellow users (see so far, not so good) but after i loaded the latest firmware, back to loading error every several seconds.  i have a roku2xd and a roku LT and both get the error.  


support has told me to try a 5GHz channel (which i don’t have on my current router) so i am waiting for my replacement router to see if that will permanently stop the loading issue.  i will post the results of my latest effort to get tablo working. 

@millerprm - my connection is wired (has been from the beginning).  I recorded many shows with Tablo set at a resolution of 1080.  In the months that I’ve had the Tablo all the recordings have played perfectly (NEVER any buffering).  Along came the last firmware update, and the buffering began (even for old recordings).  I have the Tablo set at 720, which helps, but does not eliminate the problem, and it doesn’t help when I try to watch recordings made at the 1080 resolution.  I surely hope that Tablo can fix this.

I have the 3500r stick, tablo is wired, and the video playback goes to that loading screen quite a bit. On my pc, iPhone, iPad I do not experience this… But on my tvs (all Roku sticks) it loads.

Already tried uncheckong the fast loading for live TV, changing to the Roku 720 setting and power cycling.

Any ideas?

Did you ever resolve this, If so, any suggestions…Have new Tablo 2 tuner, roku 3500r and a 2500x. Live tv continual buffering loop on both. Checked all cables, unchecked the live tv start option in tablo setup, have no probs with netflix, ps vue and all the other free channels. I record and playback withno problems. Any help appreciated!

Does it work properly on other devices? iPhone, iPad or computer?

No, it’s the same. I had not tried that but did just now…thanks for asking. The PC with Windows 8 and android phone with 4.4.2.
About 10 seconds of video, then buffering. Can pause then restart and get a longer period of video. Tablo connected to router via ethernet.

@vrodic Are the rest of the devices (Roku, PC, etc) on Wi-Fi, or is everything hardwired?
Can you try (temporarily) decreasing your recording quality to see if you have the same issue?

Only Tablo is on ethernet. Checked that router is on DHCP. Have reduced quality to 720/3000…no change. Used WIFI analyzer app & my signal is >> 40 dB re any other on that channel. Adjacent channels are clear. BUT the ROKU wifi signal from the 3500r stick are = to it. I turned off the 3500r though and no change on the 2500x’s Live TV. Thanks.