Password re-set not working

I can not sign into my account. System says wrong log-in user name and/or password. The Forgot Password option is not emailing me, no response.

I signed up when I bought my unit and started my free trial period.
Now want to upgrade to paid service but can’t get back into the system.

Tried the options within Settings but no luck. This is all done with my
older iPad (Ver. 10 OS), could that be related to this issue?

What can I try?

Check your e-mail spam folder.

Seems there is nothing in Junk folder. Don’t see a Spam folder
in my gmail.

Any chance unplugging and restarting my box might help?

Or is the Reset button better?

Using a web browser, sign into gmail here:

You might need to expand the left-hand side categories by clicking on ‘More’.
Spam folder should be there:

Found the Spam folder, thanks.

But still nothing from Tablo regarding resetting my password
or my request to sign up for standard service.

OK, with help, finally sorted it out. I had signed up for monthly service but somehow

my registration did not take. It worked with my 2nd ‘new signup’

Thx for the help.

I’ve tried to login for support with my account. I’m using safari and under passwords I have tablo account saved. I’ve tried typing in address and password, also using auto fill.
Email from tablo has activation failed.