One Roku connects, the other doesn't

I have been using Tablo successfully for a year. I have two Rokus in my home that have both always worked well. Today, all of the sudden, one Roku gives me an error message: “Failed to Connect to Tablo. Please make sure your Tablo is up to date by visiting”.

  1. Tablo is set up via WiFi in my home to all devices (Tablo is Ethernet connected to my home router)
  2. I can reach and watch Tablo via my Roku 3 (in one room) as well as my Windows PC through the web portal with no problems
  3. I can SEE my Tablo via my Roku 2 (in another room). However, when I select it to watch it, I get the error above.

To troubleshoot:

  1. I rebooted the Tablo
  2. I rebooted the Roku
  3. I uninstalled and reinstalled the Tablo channel on my Roku

Note that everything worked fine earlier in the week…it is a problem that just started without me making any changes.

Maybe time to retire Roku 2.

If you swap the locations of Roku 2 and Roku 3 is the problem still the Roku 2 or is it the Roku 3 now?

@Shane.Lipson Let us know if you can try @beastman’s suggestion. If that doesn’t do the trick, try rebooting your router - and then the Roku. Let us know if you have the same issue.

I upgraded the Tablo to 2.2.10. After that, nothing worked (neither Roku nor my laptop or ipad). I unplugged/replugged, hit the blue reset button and played with it for about 30 minutes and nothing worked.

After about 2 hours I was able to access it again with no problems.

Does it really take 2 hours to sync with all the new software???