No power, not the power supply

My tablo won’t power on. Ive read the threads and see that people have had success by replacing the power supply. I tried two other power supplies that are known to be good, and no success.

DdI you buy these replacement power supplies directly from Tablo?

No, they were ones for other equipment, but with the same power ratings.

I ran the Quad off a bench supply, it ran from 9 volts to 12 volts no issue. You can always go higher current just don’t go over the voltage. Also don’t go under the current rating. Also make sure it’s the same tip polarity, in this case positive tip.

What model are you running?

Or as users use to quote in the forum before tablo sold a replacement power supply:

12 volt at 2 amp rating. Regulated switching power supply with 2.1mm x 5.5mm plug, center positive

I just checked the power supply with a meter. 12.09 VDC, center pin positive. 1.5a rated.
It’s a Tablo Dual Lite

Open a support ticket with Tablo Support directly. If power supplies don’t work, maybe your Tablo is dead. Is it within the year of warranty?

1 Like

Yes, I’ve only been using it for a couple of months. Ive just sent a trouble ticket email to them. Thanks for the help guys.

It may still be a bad PS showing 12v but with no amps. That what mine did.

I kind of ruled that out using the same ps to power another device, but I’m bringing home my clamp meter to measure amps today.

It’s unlikely you tried another 12 volt adapter that also has a problem. Especially if you measured it at around 12 volts. Switch mode power supplies don’t tend to have many components that go high resistance on the output side. Inductors are about the only one which would have made a smell. Cold solder joints being the other. Just pretty unlikely to have two power adapters have the same issue.

Be sure to split the wires out if your going to try and measure the current draw. Can’t do two as they cancel each other out.

I actually ended up trying four different power supplies that were all identically rated at 12vdc, 1.5A. They all measured in between 12.3a and 12.9a. Yes, I will have to split the wires apart to get the clamp meter around just one of them. I think at this point it’s just an exercise in proving the obvious: the Tablo is dead.

I did notice while it was still alive that it seemed to get unreasonably hot. Do tablos usually produce a lot of heat?

That’s been a Hot topic around here it seams. Pun intended. I’ve modified my Quad heavily to address some HDD heat issues, the device itself runs hot but shouldn’t fail due to the heat. No electrolytic caps inside which are the #1 component that doesn’t like heat. IC’s can last a shorter time from high temps, however that’s not an issue most of the time for expected lifespans.