No Live TV Via Web App

Evening All,

Honestly, I’m hoping that this is some hilarious noob issue that I’m having but I can’t quite figure it out so I’m asking you.

I have successfully connected and used my tablo via a mobile browser and my roku to view live TV. However when I try to connect on my mac via the site, I can connect to the tablo, see the live stations and the guide, and even select the station I want to view (clicking the actual station number… not the show title).

However - the live station never actually airs on the laptop screen. Instead I get the TV Show Art and nothing actually plays. I’ve let it sit for an hour+ and there was no change on the screen. It never errors out, doesn’t revert back to the guide, nothing. Basically it just shows the TV art and sits there.

Anyone know what might be happening?


I think it’s in the FAQ but to watch a channel live click on the channel on the far left.

Thanks - I am doing this.

When I click the channel number on the far left I’m brought the the streaming screen, however nothing actually streams. I only see the TV Cover Art for the show that would/should be streaming.

Not sure. I just tried to watch Live TV on my Mac Book Air via Chrome browser and everything went fine. But I’m still at the 2.2.10 firmware as well.


Live TV is working on the mac through the chrome browser - not through Safari.

Anyone ever heard of anything like this?

Have you recently upgraded to the newest Mac OSX?

Google Chrome is the web browser Tablo coded for.
All others are a toss up.

Hi, yeas I’m running El Capitan 10.11.6


But its worth pointing out that this is posted right on table’s site:

“The app is currently optimized for Google Chrome browser and Safari.”

Why is this even an issue? Using HTML5 is supposed to render video equally across all browsers that support HTML5.

Yes, but some more equal than others. :wink:

Tablo’s web ui uses Web SQL.

Using a fossil…

Strangely, since Web-SQL is deprecated, I figured eventually Chrome would kill it off too, but they are holding on to it indefinitely (I can only presume their reasons go way beyond Tablo usage).

@tomass0617 What Tablo firmware version are you running? Do you have a VPN on your computer?

Hi - I am running 2.2.12 and do not have a VPN on the computer.

@tomass0617 - Have you tried clearing the cache, disconnecting & deleting the Tablo from the list (using the red x) in the web app and then resyncing?

I have exactly the same problem. New MacBook Pro with Sierra. Safari 10.0.1. Tablo works in Chrome but I just get the “art” for live TV or my recordings. Nothing actually plays.

Don’t hesitate to send our support team a ticket - we’re happy to work with you folks directly to help solve this.