"No Hard Drive" error

Third time this has cropped up. Using a ‘tested’ WD 1Tb Elements drive, and occasionally my 4-tuner Tablo just seems to forget it’s there. Disconnect and reconnect, and it works fine again.

Of course, while it’s not showing as connected, no TV is recorded, and I cant stream to my PC etc.

Any clues as to why the hard drive should keep dropping offline ? Lights were still on on the Harddrive too.


I’ve had this happen with my HDD when I would lose power when there’s an electricity outage. The fix is to power cycle the HDD, no need to restart the Tablo.

Or is this just happening randomly for you?

Just randomly. Tablo and router etc are plugged into a UPS, so power isn’t a problem, and no signs anything else lost power.

I’ve had the same issue with the same model hard drive… I believe it was listed as one of the compatible ones, but seems to cause problems for me. 

One of the reasons I couldn’t convince my wife to drop cable and switch to a lifetime Tablo subscription. :(  (The biggest thing in general for her was reliability… if one of her shows doesn’t record for a week for some reason, she doesn’t have another easy way to watch some of them and it becomes a big deal.)

Ok, happened again today. Was watching fine last night, and then when I get home from work, ‘No Hard Drive’.

Is there a log file or something that would shine any light on this ?

I have the WD 1tb elements hdd as well, and have dealt with this ‘no hard drive’ issue for months now. Prior to this past week, for the previous 6-8 weeks it seemed to have resolved on its own and worked flawlessly, but alas, I am now having to unplug/replug the hard drive every single day that there is something scheduled.  no me gusta.

WD 1 tb Elements drive and had zero problems… until this past week when I’ve had several problems with the drive going off line and not recovering.  On 2.1.18.  Coincidence?

So, no ‘official’ repsonses…which is a bit of a shame. I’m reluctant to go an drop another 60-100 dollars on another hard drive just to see if that cures the problem without at least some better idea of what to go and get.

TV has become a ‘set and forget’ technology - if Tablo wishes to break past the tech-savvy cord cutters, it also has to appeal to their spouses and significant others…and that means it needs to be up and working whenever they hit the button without having to be fiddled with every time. My Plex server has reached that stage, as has the Roku…Tablo is the last piece of my puzzle, and I’d love to be able to finally kick my $150/mo TV bill…


I also have one of the “recommended” WD Elements USB-powered portable hard drives (1GB) and I’ve been struggling with this problem for several weeks (I think since the last major firmware update, probably around October). Before then, it worked perfectly fine. If this is really a hardware problem, that seems really strange.

I do have an extra hard drive that I’m going to try since at this point I’m more interested in just getting this stupid thing working than I am in troubleshooting.

It does seem like it tends to disconnect after not using it for a while, typically overnight (say I watch TV at 8PM, then don’t go to watch TV again for 24 more hours). Whereas I’ve never had it just stop working while being actively used.

I have seen the same behaviour. I ‘watch’ Tablo on my PC if I’m working at home (more for background noise than anything else) so it’s not unusual for it to be streaming for 6-12 hours at a time with no issues. Then the next day, I can’t stream anything, check out the settings and ‘No Hard Drive’. I’ve had some disconnect issues with my Android tablet, but those appear to be related to my tablet rather than the tablo device itself.

When I get the no-harddrive issue, the light on the hdd appears to be on solidly, rather than blinking, so I’m wondering if it goes into some sort of power-down or power-save mode or something…hence the question around a log-file to see if there was some event that could be identified that may be the root cause.

Other than this issue (and a decent guide display for the Roku maybe) I have been very happy with the Tablo. If I could get a couple months of trouble free operation, I’d have a professional attenna installed and pull the plug on my DirectTV as soon as the HBO service goes live - Wife has to have her GoT :wink:


There was formal acknowledgement of this issue in another thread. They said they’re working on a fix. Follow the forums a bit more thoroughly.

Take a read here:


There was formal acknowledgement of this issue in another thread. They said they’re working on a fix. Follow the forums a bit more thoroughly.

Take a read here:

Well gee…thanks. Sorry for not catching a reply to someone elses thread - especially as my thread predated the one you referenced…but hey…I realize it’s my fault. Thanks for making sure I was properly put into my place.

I’ve posted to THAT thread, referencing the two other threads including mine where this issue is discussed, offering assistance in troubleshooting the issue. It’s really the least I can do having invested close to $500 in the product already and so grievously missing a forum reply.

No need for sarcasm. Just saying you shouldn’t be so quick to criticize about lack of official responses.

Not sure I was the first one to cop the attitude…

I haven’t received anything official…someone else did…(who actually provided less detail than I did… but whatever)

I was in the hospital all day Saturday and Sunday, so I apologize for not searching the entire forum to see if someone had replied to another post in a way that may have related to my post. Like I said before, I’ve already updated the other post to ensure Tablo is aware there are more of us that have the problem and are prepared to assist.

If you have some useful information on the problem, let me know.

Regardless hope you get your issue fixed. Or you can return the Tablo as a dissatisfied customer and get a refund on that investment.

Error occurred again this morning. Watched Jimmy and Seth last night with no issues, woke up this morning and Hard Drive is not spinning, and No Hard Drive error showing again. No lights on the harddrive at all.

Unlugged and replugged the drive, working like a champ again. I ran the Western Digitial diagnostics, no errors, no flags in SMART. Can’t tell if there is a sleep timer or something, as WD’s utility doesn’t support the drive (go figure). I also installed Extfsd on my desktop, spun up the drive there, and can access the drive without any issues…so best I can tell it’s working just fine.

Not sure if there are some logs or something that @tablosupport can use, but if there are, just let me know.

It really sounds like the drive is going to sleep as it returns to full function when you Power Cycle just the drive. The Tablo does not need rebooting so it’s not freezing on anything.

A way to test it is to set up recordings for 24 hours straight and if your drive never gets disconnected then it’s cause the drive is in use and can’t go into sleep mode.

Sleep mode usually should be reset when something tries to access the drive again. If the Tablo is unable to ‘wake’ the drive, then that is a problem that would have to be addressed by Tablo in their firmware (with maybe a keep alive or a wake-up or something).

Some days it goes 24 hours or more with no issue…last night it was barely 7 before I noticed it was showing No Hard Drive.

Sleep timers on drives are usually in minutes, not hours. While the WD utilities won’t give me the specifics, some basic testing suggests the drive sleeps after about 6 minutes, and takes about 30 seconds to spin back up. Maybe Tablo checks, and doesn’t get a response within a timeout period and marks the drive as disconnected. As there appears to be no way to disable this timer, the issue is pretty moot - either Tablo needs to handle wake ups better, or the use of external drives is always going to be problematic, as almost all of them use sleep timers of one sort or another.

I’m sure there is probably a log file or way to capture events that could shed light on the issue,

For reference, this is a WD Elements 1Tb (Model # WDBUZG0010BBK-NESN…The exact drive recommended from the Tablotv.com pages)

Not sure if this is good for the Tablo and/or the hard drive, but  if you have a Roku , try letting it go idle  without fully exiting the Tablo channel when you’re done for the day. I haven’t done any consistent tests on this theory, but so far it’s happened two or three times (accidentally), and each time the hard drive has been detected/stayed connected.

The nice people at Tablo connected into my device and grabbed some logs and tweaked something to see if it stops the issue - I’m guessing if it does, it’ll get rolled into a patch at somepoint (assuming it was the tablo that had the issue).