"No Hard Drive" and "Error Weak Signal" messages after most recent update

I have a Tablo (2 Tuner). We’ve been having a frequently occurring issue with the “No Hard Drive” error message and the “Error, Weak Signal” message, even after the last update. We can put up with the occasional hiccup in the system now and then, but the problems I mentioned are starting to become a daily nuisance.

What is the make and model of the HDD you’re using?

Western Digital Elements.

The Tablo is being used with a Roku 3. The two problems I described seem to be happening with greater frequency. Things worked fine for some time. Every once in awhile I would have to reset the Tablo or check the HDD. Now it seems to be a daily problem. We’re missing shows that we like to record and watch later.

I was hoping the update would correct this, but it seems as if nothing has changed.

If you haven’t already done this, go to the WD web site and download the WD firmware upgrade program and make sure the HDD firmware is up to date. Especially if the WD HDD S/N number ends in an “-03”

1 Like
  1. What is the exact model number of said drive?
  2. As zippy said, connect the WD HDD to your computer and use the WD utility to update the firmware. Updating the firmware has helped many with HDD disconnect issues, specifically the WD Elements drives. Search the forums. Even if the utility reports the firmware is up to date, you can force it to update which will re-install the current firmware on it. This has also helped others.

As well, some WD drives can have their sleep mode disabled via the utility. Turn this off if you can.

1 Like

Thanks, theuser86 and zippy!


I’ll look into updating the firmware. Hopefully that works. I’ll post results later today if possible.

1 Like

I have 2 tablos. One with a WD Elements ending with S/N “-04”. And one with WD Elements ending in “-03”. The “-04” never disconnected. The “-03” disconnected so many times I wanted to shoot it to put it out of it’s misery. But after the firmware upgrade it’s never disconnected.

1 Like

Do you have a link for that? I checked Western Digital’s website for that model and I got to a page that said there were no updates available for that model. I got to that page a few ways, including typing in the model number of the drive itself.

I found a Universal Firmware Updater on their site. The most recent one says the update is for My Passport users. The release notes list my drive in one of the earlier updates.

Did you have tv programs on yours when you did the upgrade?

The firmware updater is a universal updater.


WD doesn’t list firmware updates on it’s various drive update page.The updater won’t update the drive unless it’s needs it.

Here is another way to tell for the “-03” drive. Using the tablo TV PC WEB browser go into settings. Below the hard drive it lists various information. The 1049 shown below is the firmware version. This also matches the information in the firmware updater release notes.

WD Elements 10A8 1049

When using the WD firmware updater on a PC, it have no impact on any data already on the drive. When I updated I just unplugged the tablo unit unplugged the drive and plugged the drive into the PC and ran the updater. Then just reverse the process.

Another user in the forum has said they could ‘force’ an update even if the utility reported the firmware on the drive was the most recent, basically re-install the current version of the firmware. This fixed the issues they were having.

Do/did you see an option to do this?

Mine says WD Elements 10A8 1042 on the Tablo TV Web Browser settings

Run the WD firmware program and your disconnected drive issue should go away after the firmware is updated to at least 1049 or higher.


No problem updating the firmware.

Got my fingers crossed in the hopes that it works. I’ll see how it goes and post again in about a week.

Thank you so much!

Glad to hear it worked out.

Did you run a different firmware update utility the first time when it told you there wasn’t an update for your drive?

I ended up using the universal firmware update that WD had posted on their site even though it was listed for the My Passport drive. I read through the release notes for the update and it had my drive listed from a previous update so I ran it. No problems.

1 Like

@gerasco Sorry that I 'm a little late to this one. @theuser86 and @zippy we’re 100% correct on this one. The 1042 series is usually a red flag if/when we come across it. Glad to hear things are up and running now :smile:

Quite alright. Things have been running much better since I updated the firmware. We really enjoy the Tablo and I’ve been happy with the support whenever I’ve had an issue.

Many times when purchasing the WD Elements drive in an actual store only suffix “-04” and “-05” are available. This were probably manufactured more recently. I haven’t found that these drive have a disconnect problem or even need a firmware update.

My “-04” drive shows up as:

WD Elements 10B8 1012