Nighthawk R7800 not working for Tablo Remote Connection

I have tried contacting my ISP and Tablo and no real help so thought I would try here!

I have tried to use the UPNP settings on my router (Nighthawk® X4S R7800) and then enabling remote connect on tablo. Didn’t work

I removed the UPNP setting (disabled) and then set up static IP reservation for my Tablo I set up port forwarding according to what was shown in the TABLO after again enabling remote access and… Didn’t work

I previously paid the lifetime subscription for Tablo.

Now I’m not sure who to go to… ISP (Comcast) and Tablo haven’t been any real help. Maybe a different DVR service (Homerun?) or look at a different router? Netgear won’t help me either as 2017 router unless I pay like $100 for their help, which I wouldn’t be opposed to doing if i thought they would be able to fix my problem, but I’m just not sure(!) they could. Also makes me feel like if I’m throwing $100 towards help, that maybe I should instead go with a new router again.

Does your ISP provide a router as well, even though you use your own for your LAN - or it a device just with a single port for a personal wifi router?

1 Like

I have used several Netgear routers, and you have port forwarding set up exactly as I have done it. The easy way to mess it up is not have TCP listed as the protocol, but you have it correct.

You might want to delete the configuration in your router, go back to the Tablo to make sure the ports haven’t changed, and then re-add the router settings back. I am not sure where to go if that doesn’t work, but you have it correct as far as I can tell.

1 Like

Take a look at two items:
a. Under Service Name (on the page in your OP – if it allows you to enter your own name, select one other than FTP. Some routers will “key in” special settings based on the name. FTP is a well-defined internet protocol, and it may set in conflicting settings. I named my Tablo (on a different router).

b. Check your DHCP range. Often, the default settings for DHCP range exclude a block of addresses at the top ( or bottom ( of the range. Try to set the Tablo to an address within the default DHCP range.

I have a Nighthawk as well and it is working fine with a manual (non-UPNP) setup. Can you change the Service Type to “TCP/UDP” like I have below:

1 Like

The port forwarding configuration on the Netgear router looks correct.

What is the make and model of your ISP Comcast modem? It is possible the ISP modem has a built in router, so you need to disable the router function by putting the modem in bridge mode.

If you have a router running on the ISP modem and then your Netgear router, you have “double NAT” setup, google it. This would be why the port forwarding doesn’t work.


I wasn’t even sure who to reply to, but a family member seeing everyone’s posts here had me go to my modem and forward from there (instead of my router). I also ended up changing TCP to both as someone had suggested. Not sure which of those two things or both fixed it, but it’s working now. Thank you so much everyone!!

Or maybe i should say in addition to router as I left the forwarding settings on my router, but changed to TCP/UDP there. But added port forwarding to the modem setting

The problem is likely that you have a cable modem/router THEN the Nighthawk. You have to do the port forwarding on your cable mode/router.

Yes I agree with you, this is what many call “double NAT”. See links below.