Nexus player "OK" button + Harmony

I’ve got a Harmony hub and the RF programmable remote that comes with it. Overall it’s a good experience with the nexus player with the exception of the tablo app.

In the tablo app i’ve found that using the original NP remote FF or RW then pressing “ok” on the remote will jump to whatever I fast forwarded to. On the harmony however, pressing ok just manipulates the little play button but doesn’t actually jump. I need to press “play” to do the jump.

This is completely unintuitive in my mind, but it seems like Tablo is the only app that gets it wrong. I’ve found various posts online that complain about this behavior and recommend other hacky things like programming a mac BT keyboard and using the enter key, OK key or left click. I’ve tried a variety of them, but still Tablo behaves the same way.

Is there anything Tablo devs can do about this scenario? Is the NP remote sending some sort of different command than the Harmony sends? Any chance you can adjust to pick up what the Harmony sends to do the right thing?


I’m using a Harmony hub with my setup (Roku and Shield) and pressing the OK button works properly for both when selecting a thumbnail to resume play. I know this doesn’t solve your problem but just thought I’d let you know it does work for me. The only thing I would try is to confirm the button setup in the Harmony setup.

@shhern, thanks for that feedback. I’ve actually tried lots of different mappings, but can’t find one that does the special behavior of the “OK” button on the NP remote.

Curious, can you tell me:

  1. what your mapping is for the “OK” button in Harmony Hub? Is it for the OK button? Or “A” button on shield?
  2. Are you using IR or bluetooth connection? From what i’ve read online so far it’s only affected by BT connection to Android TV.

Oh and other note; yes it works properly with Harmony on Roku + Tablo. It’s only Nexus Player + Harmony Hub.

I have the exact same situation with Harmony Hub and Nexus Player. I haven’t verified this on my Shield (traveling) but will when I get home.
It’s a problem unique to the Nexus Player/Harmony in my setup (Roku, FireTV, Shield, Nexus Player).
I’ve not found a way to fix it in key mapping, but would like to if it exists.

If you can confirm it’s NP/Harmony Hub specific when you return from traveling that would be great. Please also note if you are using IR or BT for Shield.

Hopefully there is something Tablo TV dev’s can do on their end to help with this…

I have a Shield and Harmony Hub, and I never have problem with the OK button for the Shield in the Tablo app. My current setup was bluetooth, but I did not have problem even when it was IR. My only issue with IR was that when holding the right arrow key for fast forward, sometimes it would stop in the middle as if I have released the button. Setting it up with BT fixes the issue. BTW, my OK button on the Harmony is set to the Shield “OK”. (I had the Harmony 700 before and also did not have any issue with the OK button.)

Will do…it won’t be until next week though. My setup with both Nexus Player and Shield are via Bluetooth.

I will have to look this weekend after I return home from business travel as I don’t remember exactly as I’ve had the setup for over a year. Slept too many times since I set it up.

Finally was able to check it out:

Bluetooth connection and the OK button is setup for OK on the Shield.