New to Tablo "No Hard Drive"

I am new to Tablo, just setup the device today. I am using the recommended Seagate expansion 5tb drive which is self powered and Tablo SPVR2-01-NA. I had no issues getting the Tablo connected and setup, but I was disappointed to see the “No Hard Drive” message and that nothing can record. I have read through the various posts on this issue and most of them focus only on devices that previously worked and then stopped working after a firmware update. I have verified that the hard drive works fine on a PC. booted everything multiple times, tried various positioning of the usb (recommended in the forums), still no luck. I did open a case the Tablo, but have not received any response. Slowly losing any hope that this is a solid product.

Do you have any other HDDs to test with the Tablo? This will allow confirming the USB ports work on the Tablo.

What is the model number of the Seagate HDD you have?

Seagates can be a problem drive. Go get a Western digital Element drive.

Well this Seagate 5 TB drive the OP is using is a new drive from Seagate if it doesn’t have an external power source. I’m guessing the Tablo doesn’t provide enough current to power the drive. The Seagate 5 TB portable drive is USB 3.0 while the Tablo is USB 2.0

Seagate’s new 5TB drive is the largest portable hard drive ever

The Seagate drive I am using does have an external power supply, so there is no need to pull power from the Tablo. In fact, the Seagate drive I am using is one of the top two drives that Tablo specifically recommends. therefore, it would be very disappointing if the drive they recommend and say works very well did not actually work on their system. Tablo should either figure out their drive issue or include an internal drive on their systems, otherwise they will never be relevant.

I’ve been reading some issues with seagate drives and Tablos. Namely the sector size may cause issues with a Tablo recognizing the drive.

@jranchg Were you able to get this up and running? If not, give our support team a shout. We can take a look at your unit from our end.

After much frustration, I figured out how to make the Tablo device see a hard drive. I have the WD Elements 1 TB drive, as suggested by Tablo. The problem I experienced was that Tablo would not show or connect to my USB drive during set up. So I decided to do a full format (not quick) on the drive using my desktop computer. That took over 4 hours. Then I started the Tablo set up process again on my tablet. This time, Tablo saw the drive! It gave me the option to format the drive again, so I did. At the end of the format process (4 more hours), the drive was displayed, set up completed, and it records programs like it should. I think the key is to format the USB drive on a desktop computer prior to initiating the installation process.

The Tablo should not have taken 4 hours to do a full format on the drive. Maybe the drive is defective.

Even on the computer a full format should not have taken 4 hours for 1 TB.

Maybe it needs a firmware update, the WD drive that is