NEW - Tablo Firmware Release 2.2.32

I didn’t know it had been promised for a long time.

I always thought there were 3rd party apps that did that.

Maybe when it works on all platforms not just the apple ecosystem.

Read the release notes.

A July 2017 responds to a question said it was on the roadmap. No date was given. Usually, when something is on the roadmap, it is hoped to be completed in a short while. It’s now 3.5 years later. This is the string:

Did not see anything listed. What did I miss?

If you missed anything it would be that it wasn’t included in the release.

A small product’s roadmap could have 100’s of items on it. Including maintenance fixes.

New items appear. And every budget cycle things get prioritized.

But did 2 items drop off of the how things work web page.

"They" use on the roadmap often throughout the forum, and… in support articles, since the beginning of tablo’s time. To be fair, so things mentioned have been check off - many more remain.

Although it often kind of feels like a feel good blow-off buzz word comment this post helps put it into perspective:

Sadly, there no updates to what users don’t know…

Things change all the time, and this constantly effects the release cycle and roadmap as a whole.

Trade secrets I suppose. :frowning:

Heads up…manually scheduled recordings are deleted after a channel scan followed by a guide update. I have an older SPVR4-01-NA model, and I recently upgraded the firmware to 2.2.32. I have a 4 manually created schedules, and all 4 disappeared from my scheduled list after a channel scan followed by a guide update. It is possible that just updating the guide is deleting my manual recording schedule. Other scheduled shows added from the grid (not manually created) are not being deleted. Note only the schedule itself is deleting the manually created ones. This is not affecting any recordings I did previously, they are all still there.

1 Like

Note: although there are no comment accepted, I did click submit a request link: Telling “someone” how outdated this was. As one app was wayy outdated and there were others - for all platforms.
OTA2Go even had a “guest blog post”.

I got a canned response, and tried again and realized it was pointless.

I am aware of Tablo Ripper, APL Tablo, Tablo Tools, SuLa Tablo, Capto, OTA2Go. I was pointing out, you mention 2 references in this outdated article, one is no longer functional. Although Tablo Ripper is extremely popular, others are great as well, had a “guest blog post” about OTA2Go Download Tablo Recordings to your Android Device with ota2GO | Over The Air (OTA) DVR | Tablo and it’s not even included.

THE ARTICLE IS OUTDATED, is what I was pointing out. sorry for the inconvenience.

On Mon, Dec 28, 2020 at 6:37 PM Tablo <> wrote:
##- Please type your reply above this line -##

Your request (91695) has been updated. To add additional comments, reply to this email.

Tablo Support - Sarah (Tablo)

Dec 28, 2020, 6:37 PM EST

Hi there,

Unfortunately, we have no supported use case to transfer data between drives, devices, or directly to a PC.

However, one of our community members developed an unsupported third-party application called Tablo Ripper, this will enable you to rip the Tablo’s hard drive content directly to your PC
The official Tablo Ripper community thread can be found here:

Tablo Ripper - Automatically download new recordings - #1307 by dcol

The Tablo Ripper website can be found here:

Home · cyclej/TabloRipper Wiki · GitHub

I hope this helps. If you have any further questions please send us another email.


Tablo Support
Monday-Friday 9:30 AM - 5:30 PM ET


Dec 26, 2020, 7:55 AM EST

Can I download Tablo’s videos to my devices for offline viewing?

This 2017 article is extremely outdated!

Also lost my selected channels, all schedules went back to defaults

Did you do a channel scan after the firmware update?

I just checked and the scheduled shows still have correctly selected channel to record from (this is after the firmware update but I didn’t do a channel scan).

Great, now I’m afraid of doing a channel scan.
Screw it, I’m doing a channel scan…
Nope, chickened out.

Ugh, can’t stand it anymore.
I’m scared.
Hold me.

Rescanned channels, selected all previously selected channels, plus 1 new channel, just to mix things up.
1st updating guide pass completed.
2nd updating guide pass stuck at 0%.

I won’t sweat it, though.
Chances of losing power, or internet service is only 100%.

2nd updating guide pass stayed stuck at 0% for over 30 minutes, however, after disconnecting, and reconnecting the guide status stated last update was completed an hour ago, so I’m thinking it was just a status fluke.

Everything is working properly, except one scheduled recording indicates there’s scheduled recording within the next 2 weeks, but there’s no actual recording event.

Series summary:

Episode details:

Every other series scheduled recording with no episodes to record within the next 2 weeks would display this instead:

@TabloTV This is the only non-standard guide/recording issue I found.
Nevermind, just realized the problem scheduled recording was the only one set to record all episodes, the rest are set to new.
Changing all to new, and then back to all fixed the status symbol.

Wait, just realized the channel scan I did today is the 1st time all channels displayed 5 green circles.
All 44.
I feel like I did when I received an A+ on a math test in grade school.
Beaming until realizing it was another student’s test.

Please don’t let this be another customer’s channel scan results.

:rooster: I"m waiting a couple of more days just to update, see who has issues and who has sucess. :tv:

Yes. Just tried it again. Ran channel scan, added channels, guide updated. Manual recording I had setup is gone, all selected channels set back to default. The guide update took a lot longer than I remember, it looks like its reloading the entire guide.

I opened a ticket with support.

I have 3 tablos one of which is a dual64 which contains zero recordings. It’s been turned off for 3 weeks due to lack of anything worth recording.

I turned it back on so I could test the new release. But it’s not it’s turn yet.

This seems to be a bug, I can confirm this also happened to me.

I did a new channel scan today, added 16 of 36 found channels. All my scheduled recordings where I had selected a specific channel have now been reset to “Any” (the default).

I have multiple tablo units. And when I disconnect and switch to another unit using a Roku it is constantly asking if I want a firmware upgrade.

And regardless if I answer “Later” is keeps asking again and again. Don’t they believe me. Is it a trick question.

This seems to be a bug they fixed a number of releases ago.

Isn’t this how it always worked? When you disconnect from Tablo A and then connected to Tablo B, if Tablo B needs a firmware update it will notify you.

The simple answer is no.

If you can a number of years ago you would find that if you answered “later” using a browser a cookie was mostly likely stored you system.

The next time you brought up the browser the settings page had a new item for update firmware. Once you updated the firmware the item magically disappeared from the settings page.

Then it got broke. And you were constantly asked. and since I have 3 units they never get the upgrade message at the same time but within a 2 to 2.5 week cycles. I currently only have 1 out of 3.

And since most releases don’t have any features or bug fixes I’m interested in, I usually wait until installed release + 2 is announced before I upgrade to installed release +1. So if I had to wait 4 months constantly getting the firmware upgrade message I would have tossed tablo into the electronics junk pile years ago.

Here is the example. I have 3 tablo units. Only tablo2 is available for update.

If I start the tablo app and connect to tablo2 I get no firmware upgrade message. Probably because I had previously answered the question as “Later”.

If I disconnect from tablo2 and connect to either tablo1 or tablo3 I get no firmware update message because they are in the update list.

If I then disconnect from tablo1 or tablo3 and connect to tablo2 I now get the upgrade message. Does this seem like normal behavior.

Yes it does, I only have 1 Tablo but even with the old firmware 2.2.30 every single time I connected to the Tablo on the Roku I would be asked to update even if I had previously clicked “Later”. Every single time I would be asked until I did the update. This is not new to version 2.2.32.