NEW - Tablo App for Amazon Fire TV Update (1.3.4)

1 Like

@TabloSupport & @TabloTV

I received an update to my 4k stick the other day.
I now have zero issues with playback.

I don’t know if they fixed it or if as I stated before having mx player / vlc players installed plus the update.

But it’s working beautifully… hopefully some others reading this will try it…

to install vlc use the “Downloader” app in the fire tv store, then use it to install vlc…

Hrm… Ours is still showing OS (build 1196) which according to Amazon is the latest.

We’ll try your workaround and see if it does anything on our end.

I also spoke to dam soon…
live TV video is jerky (panning camera movement)
I’m going to hit record and watch the recording

yep, it wasn’t doing it before, now it is… :thinking: :thinking: :thinking: :thinking: :thinking: :thinking: :thinking: :thinking: on both record and live

We’ve always seen it on both recordings & live TV.

I can confirm both the Table and Tablo Preview apps do not work with the Amazon Fire TV Cube. There is constant stuttering and both live and recorded content.

Very disappointing to read this has been an issue since January and it’s still not fixed. I wish Tablo would hurry up with a work around, I don’t believe Amazon is going to do anything on their end.

Let me know if there is anything I can test to help out.

At least we all know now that it still exists on the Cube.


Thanks for the heads-up.

As mentioned, this is one of our top priorities but the going has been slower than we’d like.

We’ll be sure to keep everyone posted in the meantime.

I too have the same problem with the new Fire TV Cube. There is constant stuttering in both the live and playback modes.

Unfortunately, I believe you are correct here. Amazon has no motivation to fix this. In their world there is no problem - there are not enough Tablo users to make it relevant for them.

Just installed my new Amazon Cube and am experiencing the motion jitter noted above. Makes it impossible to watch. Interestingly it did not happen with my Fire Stick I purchased in Janurary which was moved to another tv. Make me want to :face_vomiting:.

I’ve had it with the Tablo device… I don’t care if you keep telling us this is a FireTV issue. It doesn’t matter. The Tablo simply doesn’t work with current FireTV 4K devices. I founght this for over a year now and all we get is excuses. Sure, the Tablo app works with OTHER media boxes, but OTHER streaming services also work just fine with the FireTV!

Its pretty obvious that Amazon is NOT going to fix this. So how bout you guys step up and modify your data stream so it works with the current crop of FireTV devices?

You can blame it on Amazon all you want but you could also fix it on YOUR end if you REALLY, REALLY wanted to!

All that matters is that ITS NOT WORKING and it hasn’t been for well over a year! If YOU are not going to fix your data stream then its pretty obvious its not ever going to be resolved. Its as simple as that!

1 Like

Actually, the new FireTV cube isn’t working properly with other streaming services I use, including Netflix (random pausing and unpausing) and Hulu (random FireTV rebooting). There definitely is a problem with the FireTV 4K devices.

Today I posted a detailed negative review for the FireTV cube on Amazon’s website. Surprisingly, I received a phone call from Amazon’s customer service within 2 hours. I made arrangements to follow up with their development team next week, so we’ll see how it goes. I will post any info that comes out of that conversion.

Yup, we did that last fall for the current Gen 4K FireTV (Amazon really hates negative reviews)…

Similarly, I suggested (in the “FireTV Cube is incompatible thread” on this forum) everyone post a detailed negative FireTV Cube review on Amazon …

Don’t forget to post a similar one star review for the Tablo device as well. (Tablo shares responsibility for how their streams are encoded, and how their FireTV app performs, as well)…

Update here for everyone:

I said the same thing 25 days earlier.

Since the Cube probably makes up way less then 1% of the current tablo Set top Box devices, why not just add a temporary setting flag that allows those users to record in closed GOP mode.

The Cube must support closed GOP. They pay all the side affects: larger file sizes, forward/backward motion, etc. And if Amazon ever fixes the issue you can remove the flag.

I found a solution to this problem that completely fixes the issue–works 100% on Amazon Fire Devices, including the new Fire Cube.

It’s call Plex. I connected a Hauppage TV tuner to my Windows computer ($65), connected my HD antenna to the tuner, downloaded the Plex software to that computer, and added the Plex application to my Fire devices. Problem solved. Next, I am going to use my Raspberry Pi to host the Plex server software, connecting the USB tuner to it. The Plex software includes the DVR for my over-the-air broadcasts.

Sorry, Tablo, but you can’t put your customers on hold for more than six months and still not have a solution to your problem.

Hey folks -

A firmware workaround is on the way:

1 Like