New Router & Remote Access - Ugh!

My old Arris router died and Spectrum gave me a Technicolor TC8715D as a replacement.

I have been unable to get a successful port mapping. Tablo wants:

21011 -> 8887
21010 -> 80

Shouldn’t I just be able to put the Tablo in the DMZ and be done with it?

I have been all over this new router and can not find any way to actually map the required ports.

This forum is my last hope before throwing down for a Surfboard and a Netgear AC1900 (R7000).

Thanks for any help or advice.

From the manual for your combo modem/router, it looks that it does not allow you to translate ports, that is forward a public port number to a different private port number. This is required for the Tablo to work, as in 21011 to 8887 is port translation.

The modem has UPnP, so you can try having the Tablo automatically configure the port forwarding. Make sure UPnP is turned on in the modem settings (page 56 of the PDF).

See page 58 of the PDF manual for port forwarding.

Your only solution may be to buy a new router such as the R7000 but you don’t need to buy a new modem, just call your ISP tech support have them put the current one you have in bridge mode.

See thread below for bridge mode for a similar Techicolor modem (slightly newer model).

1 Like

Thanks so much!

You have been an amazing help. I didn’t even think of finding a manual for the router.

I will review the manual (RTFM as we used to say) and post back.

Again thanks for going way “above and beyond” for me.

1 Like

No problem - the manual port forwarding seems to be only 1 to 1 NAT, however the port triggering allows port translation so that might work for you.

But give the UPnP a try first before trying the port triggering.

I had an old router that was giving me trouble with remote access as well as other issues. Finally replaced it with a new Netgear R6400. Excellent router. I tried several times to setup port forwarding manually but it would never hold and the next day it would tell me again I needed to setup port forwarding. I finally turned off the ports I tried to forward and almost immediately it started to automatically setup remote access for Tablo. Must be the UPnP doing it’s thing. Remote access has been working great ever since.

Update: Actually what I did was turn off remote access for several weeks after not being able to manually set it up. Got very frustrated. I also eventually deleted the ports I manually setup in my router. When I turned on Tablo’s remote access again it then automatically set it up and everything has worked fine since.


I had that Technicolor router when I first got my Tablo and after a lot of trial and error I discovered it would work with upnp. Good luck!

1 Like

Thank you all for the great help and information.

After spending a few more hours trying to tame this beast, I have decided to put it in bridge mode and go with the Netgear R7000 which I am familiar with.

Thanks all for taking the time to help me out!