New hard drive needs to be formatted

My hard drive failed and when I put the new one in I get a message that it isn’t formatted and to go to to format. However I find nothing there to do so. I go to settings and it says my hard drive is not formatted but no way to change it.

1 Like

Try unplugging the Tablo… plug the hard drive in to one of the USB ports and plug plug the tablo in. Go to and it should allow you to format the hard drive.

I also find nothing useful in Any other suggestions that don’t entail a complete reset of the Tablo box?

Just guessing, but a full reset might be necessary as the Tablo does maintain a db of sort on internal storage (not the drive). If the drive were “replaced” and the interior meta data stayed in place, it might get really confused (?).

I’ve discovered, contrary to tablo’s instructions, power up the tablo. Access settings via browser on PC or android app. THEN connect and/or power the drive. About 30 seconds it recognized the drive and offers a format option.

I’ve recently done this with a new tablo, then changing drive on it. Each time, power the tablo… then the drive – works for me. Your experience may vary.

1 Like

I’ve been trying to figure this out for an hour and your suggestion was spot on! Thanks so much djk44883 for your suggestion!

1 - Power on tablo without hard drive attached
2 - Connect to tablo app or browser app on pc
3 - Go to settings page
4 - Connect your hard drive
5 - You will get a prompt to format!


Would that be the best method with the Quad as well? I’m ready to upgrade to a larger internal drive and would like to accomplish it without a complete reset if possible.

My experience is exclusively external USB devices! Internal has a SATA interface, I wouldn’t recommend installing it after the device powers up.

Thanks, I swapped the drive and did a complete reset with no issues. Took a screenshot of my channel lineup in advance. Got the format prompt right away, which isn’t always the case.

I’m setting up my Tablo dual lite and it is not recognizing the new WD elements 2Tb drive. I’ve cycled it on and off numerous times and did the above and it still says no drive recognized. I plug the drive in and you can hear it working and the little drive light goes from flashing to solid. Yet no drive recognized… No prompt for formatting the drive either.


Hope you got it by now… In the past when I haven’t gotten the FORMAT prompt I connected my drive to a Windows pc via usb and used “Computer Management / Disk Management” to remove all disk partitions. My Quad would then immediately offer to format.

…just to confirm, you’re using a device/app capable of initial set up? Not all have the availability ie)

Note: The Roku does not currently support initial setup of your Tablo. You’ll need to complete this via one of our other apps (iOS, Android or web).

just asking

Yes, I’ve tried on both my new Android Tab A 10.1 tablet and on my computer going in through Google chrome…

@kens450r Give us a ring or drop us a note. We can poke at the drive from our end and see if it cooperates:

I tried the drive on my computer and then took it into my IT manager.
He said it is a defective drive right out of the box… Have contacted Amazon and will be returning it and waiting impatiently for it’s replacement to get to my house.

I’m pumped about getting the Tablo set up so this is a bit disappointing I have to wait another week…

Thank you for the follow up.

Discouraging as it it… at least you know. It’s not you or your tablo :slight_smile:

@Rick_S Thank you for the step by step! Worked perfectly.


New user here. Found this topic and thought I would add my issue. In my case it’s an internal HD not an ext USB that can be powered separately. I’m trying some of the suggestions here to no avail.
So wondering if there is anything different that needs to be done if using an internal HD vs the ext USB connected?

I received the Quatro yesterday and used a 750 GB internal drive and all went well. Today I replaced it with a larger 2 TB Blue WD drive.

Update: Figured it out by simply doing a reset. Which I had to read the specifics on how to accomplish.