NEW Firmware Release - 2.2.14

Unfortunately, I just did the upgrade to 22.14 and now my 2 channel Tablo no longer will show live shows. I hate it when companies put out software that hasn’t been tested.

My Tablo has been working for about the last 6 months without a hard drive. It never did recognize any external hard drive I tried although it would recognize a thumbdrive. The thumbdrive didn’t work very well though as it caused the live tv to stutter but since it worked just fine without a hard drive, I was ok with that.

Now it will give me an error message that it can’t play the tv. I don’t even know how to back out of the bad version and go back to the old version. If it isn’t fixed soon I guess I’ll have to update my review on Amazon.


Here is how to toggle back to your previous firmware:

No 2.2.14…yet?

My 2-tuner finally updated to 2.2.14 yesterday evening. For a short time (5 mins?) the Tablo was not accessible via the Chrome web app, I assumed this was the “post-upgrade database process” alluded to in the announcement. After that I was able to access the Tablo normally.

@MikeInOregon - maybe a factory reset of your unit would help. Since no HD is attached you have no recordings to lose.

1 Like

@MikeInOregon @Collarmobia @dhanger

If any of you are still having issues, please don’t hesitate to PM me directly, or to send our support team a ticket.. This firmware load was tested thoroughly by our own team, and by our beta testing community. I’m sure we can get you up and running.

I’m on the beta team and I spent a month and a half and 4 separate revisions testing this software

[We do NOT currently support:

USB Flash storage – Flash is simply not fast enough
Networked (NAS) storage – There is too wide a variation in network speeds to support this](

7 Days since it’s release and still a no show on my device. :frowning:

Got the update for 2.2.13 and have been ignoring it since the system was nice and stable but not getting any notice for 2.2.14 at all. Finally upgraded to 2.2.13 the other day hoping that might trigger the update to 2.2.14 but still nada.

Any suggestions?

You could try rebooting your Tablo to see if it goes looking for a firmware update.

We’ll be opening the release to a large batch of units today. Stay tuned!

Okay, I’ll stay tuned. Just figured since I get the Beta’s and such I’d be getting this early as I always have in the past.

I have 2 Tablo’s. I finally received an update on one of them today. The other one not yet.

The selection is totally random, so it’ll be different each time around.

@Spunky03 Just so you know, you’re not alone…I’m also a beta tester, but still haven’t received 2.2.14. Like you, I thought we’d be the first to see the final release, but @TabloTV must be correct that it is just random.

1 Like

I still haven’t received 2.2.14 either

Same here haven’t received too… I have 4-tuner… Still on 2.2.12 version… Not in a hurry tho

“They also serve who only stand and wait.”

John Milton, from “When I Consider How My Light Is Spent”

This classic poem by Milton is about his use of television before the DVR:

When I consider how my light is spent,
Ere half my days in this dark world and wide….

1 Like

lol I’m in no rush to get 2.2.14 - my Tablo is running fine on the 2.2.13 beta

1 Like

I am still happily running 2.2.10. Tablo is going to need to provide me with a compelling reason to upgrade firmware (a risky proposition at best) before I take the plunge.

There hasn’t been any new features or fixes in the last 2-3 releases of any interest to me.

But no matter how many times you select to upgrade “later”, there is always someone in the household that selects to upgrade.

Last night my Tablo would not connect.

I suspected maybe the update had showed up and was causing this problem so tried to do a reset by holding the button on back of the unit but it had no effect. I then unplugged it for 30 seconds and powered it back up. Upon launching the app (Fire TV2) it immediately showed that the update was available which I allowed to complete. After it rebooted I restarted the app and it quickly connected and all seems fine.

However, my scheduled recording of Survivor which should have taken place about an hour before all this did not record ;-[.

1 Like